Smush CDN slow down my site

I activated Smush CDN and my site stopped loading. After I disable the CDN site loads fine, can you help me?

Also, I'm trying to make my site faster, can you check what I can improve on my website?

Thank you in advance.

  • Prathamesh Palve
    • Staff

    Hello SABER,

    I hope you are doing fine today and thank you for giving us time to check this for you.

    Here is a list of steps I have taken:

    1. Enable Smush( Images vanished after enabling smush CDN)
    2. Checking Lazyload Conflicts( Yes, I see that the owl carousel already supports lazyload by default)
    3. Disable Lazyloading for Home Page & all other pages.

    Reason for taking step three:

    After checking the home page and other pages, I see the lazy loading is running already. If we enable Lazyload for these from Smush, they would be conflicting.

    After checking this page: view-source:https://berkshirefurniture.com/product-category/featured-products/collections/verbois-bedroom-collection/?orderby=title&order=ASC

    I see that there is already lazyloading which makes us turn off lazy loading for it( Lazy loading from WP ROCKET plugin is already ON which would bring conflicts if the lazy loading is enabled from multiple plugins. Here is the screenshot for the same:

    Should you have any doubts further doubts or need any help, please reply in the thread here and we would be happy to help.

    Regards,
    Prathamesh

  • SABER
    • WPMU DEV Initiate

    Hi Prathamesh,

    Lazyload on my smush is off. so is the lazyload on wp rocket. actually wp rocket is inactive right now. so should I turn the lazyload of smush on or no? please check to make sure it will not conflict with the site.

    Thanks
    Saber

  • Prathamesh Palve
    • Staff

    Hello SABER,

    It should not conflict if lazy loading would only be turned on from one plugin. Adding to this, I could not test this on your site as if I turn on lazy loading, I would also need to clear the cache from Hummingbird. While I tried to clear the cache, I spot that the directory permissions to your site are wrong.

    Kindly set all the folder permissions to 755 and file permissions to 644, try to clear cache from Hummingbird-> Caching section. If that works, please turn on lazy loading in Smush-> Lazyloading and clear the cache again from Hummingbird-> Caching section and check if that works correctly.

    I am looking forward to hearing from you.

    Thanks,
    Prathamesh

  • SABER
    • WPMU DEV Initiate

    Nebu John
    12:53 pm
    I just checked if I can purge the cache. Allow me a few more minutes.

    12:56 pm
    I can see that, even though we clear the cache, Lazyload is not working properly. I suggest you update this in the thread so that Prathamesh could better help you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.