Smush CDN urls shows multiple urls and

It appears as though (at least to me) that there is something really wrong with Smush Pro. It seems to be generating very unusual amounts of unnecessary source code on my page for images.
If you look at my page, you will see that three little images have almost 500 entries from the smushcdn. View the source code and search for “stephanie”. I can see multiple URLs for smushcdn and <noscript> tags.

  • Nithin
    • Support Wizard

    Hi Carl ,

    I could notice the issue in your website side, however, the images URL loading via scrset is the common workflow when Smush CDN is enabled to ensure responsive images are loaded based on screen size.

    That’s for example:

    <img alt="Conservative City Councilwoman" title="Stephanie Endres City Councilwoman" data-id="45" width="69" height="69" class="tve_image ls-is-cached lazyloaded wp-image-45" src="https://781622.smushcdn.com/1467495/wp-content/uploads/2019/09/StephanieEndresX69.jpg?lossy=1&strip=1&webp=1" data-src="https://781622.smushcdn.com/1467495/wp-content/uploads/2019/09/StephanieEndres-150x150.jpg?size=69x69&lossy=0&strip=1&webp=1" scale="0" data-resize-detection="0" srcset="https://781622.smushcdn.com/1467495/wp-content/uploads/2019/09/StephanieEndresX69.jpg?lossy=1&strip=1&webp=1 69w, " sizes="(max-width: 69px) 100vw, 69px">
    

    However, I could notice the <no-script> tag as you have stated getting loaded which shouldn’t get generated in general. To troubleshoot further I created a staging website and disabled the Smush Pro plugin.

    I could still notice the <no-script> tag was still being loaded, and the image URL still listing out Smush CDN in there. If the Smush Pro is disabled, it shouldn’t be serving CDN URL in general, but that isn’t the case here.

    I’m afraid, this seems more like a conflict with Thrive Builder. It looks more like the Smush CDN links and <no-script> tags are served only when thee plugins related to Thrive is enabled,ie even when Smush plugin was disabled.

    It seems like either the Thrive is serving cached template or something specific within the Thrive plugin settings. Does the plugin have any cache features?

    Please check the staging site to see how the homepage behaves when all the plugins related to the Thrive is disabled in the main site and enabled. You can get the staging details in your hosting panel under the “Staging” tab.

    I tried to change the images in the staging site to see whether that helps, but the issue still exists. Since it’s a 3rd party plugin, it’s tough to say whether there are any settings which are being missed. Would highly recommend you to bring this into our Thrive plugin supports attention to see what could be causing the issue so it could be looked upon closely.

    Looking forward to hearing what the Thrive team has to say regarding this so that we could check further if needed. Please do let us know how that goes.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Carl ,

    On further testing, it seems like there is a compatibility issue with Thrive, and Smush Pro. Since it’s a 3rd party premium plugin, we don’t have the plugin version to troubleshoot the issue further on our side.

    I would like to test the Thrive plugin on my test server, I downloaded the “Thrive Architect” plugin from the staging site so I could test in my side, but it seems like it requires a license to activate.

    Could I know the email address and the License key to activate the plugin, so that we could further troubleshoot the issue?

    You can send the details via our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    – E-mail Address
    -License Key
    -link back to this thread for reference
    -any other relevant URLs

    If there is any other way to activate the plugin without the key, please do point out that too. Please do follow up on the ticket once you have sent the above credentials. Have a good day ahead.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Carl ,

    Thanks for following up via email. On further testing, the <noscript> tags are added by Thrive Dashboard plugin which is common action done when it comes to adding Lazyload features so that it allows Google, and other Search engines to read images.

    I tried to replicate with the Thrive Architect plugin, and the default WordPress theme on my test server but wasn’t able to replicate the <noscript> tags getting created in general. Unlike on your staging, where the same steps caused the <noscript> tag to load. Seems like one of the specific settings in Thrive is adding the <noscript> tag, and it isn’t related to Smush.

    Since it’s a 3rd party plugin I’m not fully sure which exact setting would that be. I’m bringing these anomalies into our developer’s attention to see whether there is anything that could be done via Smush Side.

    However, this looks more like an issue with how the <noscript> tags are added which is caching the Smush CDN URL, so would appreciate if you could bring this into Thrive teams attention to see what they have to say regarding this so that we could have a better idea too.

    Please do let us know about the plugin supports view on this so we could check further if needed:
    https://thrivethemes.com/forums/

    Will keep you posted once I get further feedback asap. Have a nice day ahead.

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.