Smush dashboard says already smushed images needs smushing

When I use smush to compress my images, it all works ok, but when I come back to the smush dashboard, it says they need smushing again, so, at the moment it says: you have 186 attachments that need re-compressing!

  • Adam Czajczyk
    • Support Gorilla

    Hello Colin

    I hope you're well today and thank you for your question!

    I checked our site and I could replicate the issue there. I notice that you got some server-side cache on site so I've excluded "/wp-admin" from it (in fact it shouldn't be cached unless it's really more of a "static" site) but to no luck. I also tried to temporarily disable StackCP cache but that didn't change anything either.

    I tried that because it seems like the images are actually smushed but the data about them being smushed is not properly updated. This is often caused by some caching issues and that's why I checked this.

    However, I'm not familiar with your host and I'm not sure how caching works there. Could you please get in touch with them and ask them if there's any additional db/object cache running on server? If yes - if they could either temporarily disable that or at least clear it up for you?

    If that's not the case/not possible or still doesn't help, let me know please and I'll "dig deeper" into the issue.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.