Smush doesn't compress original images

I activate smush original images option and Smushed all images. But still, both Hummingbird and Google Insight shows some images needs to be compressed. Looks like these files are the original images.
How can I solve this?

  • James Morris
    • WordPress Enthusiast

    Hello Coffeegeek

    I hope you are well today. Love the username, BTW! :coffee:

    I've checked your site and it seems that your Smush settings do not have Super-Smush and PNG to JPEG conversion options enabled.

    Please keep in mind that Smush's base compression algorithm is very conservative. It will compress the largest images, but images where there may be a minor loss in quality will be left alone. Hummingbird (and most performance tools) do not discern this difference. So, if you want to squeeze that last bit of optimization out of your original images, you'll want to enable to two options mentioned about, re-check your images and Bulk Smush them.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris :coffee:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.