Smush Is Reverting to HTTP Instead of HTTPS

Hi, I hope you can resolve this quickly.

I've got an httpS site but only realized now that WP Smush Pro is pointing to plain http links after "smushing".

I don't see anywhere to set it, and this is a major issue for me since I constantly point out to my readers that my site is https enabled with a green bar. By "smushing" the images the green bar is no longer showing since your plugin is pointing to plain http.

Thanks,
Sam

  • Kasia Swiderska

    Hello Sam,

    Please provide exact steps to replicating this issue because I'm testing on my SSL site and I can't replicate. What I've done to test:
    1) I disabled automatic smushing
    2) Added new post with featured image, image in post and gallery - post has green padlock
    3) I smushed all the images I added to that post.
    4) checked post - still green padlock.

    Please advise.

    kind regards,
    Kasia

  • Rupok

    Hi Sam,

    So sorry for the inconvenience you are having. This is really weird and should not happen. When my test site is configured with SSL, my smushed/non-smushed all images are under SSL.

    Can you please confirm if your Site URL and Home URL in "Dashboard > Settings > General" section both has HTTPS in the URL?

    Actually, I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Sam,

    Hope you are doing good today. :slight_smile:

    I checked your website, and it seems like the issue isn't related to Smush Pro plugin. I could notice Mixed content error in your pages, it seems like some of the images are still loaded through http irrespective of the Smush Pro plugin. Did you change your website from http to https? If yes, that would be the reason, because the older images are still in http.

    You'll have to either re-add these images again, by clicking the Add Media button when editing your post, so that the images are back to https protocol. I did that for the /penny-millionaire-review/ post, and you'll notice the green padlock is back in the admin side.

    However, in the frontend the images in the sidebar are still loaded via http. The easiest fix for this would be to make use of a plugin like SSL insecure content fixer, so that you don't have to re-add these images again.
    https://wordpress.org/plugins/ssl-insecure-content-fixer/

    For more info about using the plugin please check the FAQ section. I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.