Smush keeps smushing images

Smush is showing that there are hundreds of images. Even if images are already smushed, Smush keeps on smushing.

  • Adam Czajczyk
    • Support Gorilla

    Hello Zac,

    I hope you're well today and thank you for your question

    I checked your site and I think these is a matter of some "broken" images in Media Library. WP Smush Pro is reporting two images that needs smushing and when I switched Media Library view to "list" I found that these images appear "broken":

    "Zac Hansen Consciously Awesome Co-funder"
    "Zac Hansen Consciously Awesome Co-funder 900x600"

    When you upload an image to the site, WP automatically creates multiple additional images out of them and also adds them to the database. In case of these images, the main image seems absent. WP Smush is finding it in database and tries to optimize them but it can't find files. Then, it still detects them in database so it keeps telling you that they need optimization.

    If you either re-upload missing files to the site or remove these images (if they are not used on the site), that should fix the issue.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Zac!

    I accessed your site again and it showed me also that there's still 10 images that need smushing. However, once I run "bulk smush" on them, it changed to "All images are smushed and up to date", see screenshot please:

    Then I left your site and accessed it again to see if it changes, but it didn't - I still got "All images are smushed..." message. I do see that there still might be some issue as my colleague Dimitris saw "all smushed" even without doing anything, while both you and me we saw "10 images need smushing" message.

    That said, if you clear your browser's cache, access the dashboard again and check "Media -> WP Smush" page now (after I run bulk smush), do you still see that there are images that need smushing or does it now show that all are smushed?

    Kind regards,
    Adam

  • Zac
    • Site Builder, Child of Zeus

    Adam,

    I cleared my cache and hit recheck images in chrome. Hit recheck images and It says I have 141 images that need re-compressing.

    I then cleared my cache in firefox. It said I have 10 images that need smushing. I hit re-check images and it said I have 141 images that need re-compressing. I labeled the screenshot from fire fox with the word fire fox.

  • Predrag Dubajic
    • Support

    Hi Zac,

    Mind if I jump in here :slight_smile:

    I was checking your installation and it looks like the issue is still with that broken images.
    When I check those images via FTP connection they are all there, the thumbnails are created and if I download the image from there it will open fine on my PC.

    However, if I try accessing that broken image or any of it's thumbnails via browser it will redirect me to your home page.
    For example, if we compare one of the thumbnails from broken image and from one that's working you can see that broken image URL is redirecting to home page while working image thumbnail opens fine, check these two URLs:
    https://consciouslyawesome.com/wp-content/uploads/2017/04/Zac-Hansen-Consciously-Awesome-Co-founder-900x600-300x200.png
    https://consciouslyawesome.com/wp-content/uploads/2017/04/Pinterest-Image-200x300.png

    Because of this Smush also can't access those broken images and optimize them.

    I would suggest trying to disable your plugins and switch to default WP theme to see if broken image is accessible after that, or try re-uploading it after everything is disabled to see if thumbnails will be accessible after that.

    If that doesn't return any results try getting in touch with your hosting provider so they can check server logs and see what might be blocking access to those images.

    Best regards,
    Predrag

  • Zac
    • Site Builder, Child of Zeus

    I went through all of the troubleshooting tips above.

    They did not work so I contacted Siteground. They regenerated all of the thumbnails and checked the sever.

    I ran WP Smush again and it went through the images. I then hit "re-check images" and I still have the same problem.

    What do we do next?

  • Predrag Dubajic
    • Support

    Hi Zac,

    I have called in Smush developer in here to check your installation and it looks like those 10 images are already optimized and since Smush calculates that there will be no size change after smushing it skips those images.

    When this happens the smush should still include those images in number of optimized images but for some reason this is not happening on your installation.

    Developer has noted this issue and will work on further improvement for showing correct number in future updates.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.