Smush not auto smushing.

I am having a problem that it's not auto smushing the images. All settings seem to be OK. Please help.

  • Adam Czajczyk

    Hi Binti Cuater Ora

    I hope you're fine today!

    I checked your site and while I can confirm the issue I wasn't able to identify the reason for it, yet. I know that there's been a conflict test run but not all the plugins were disabled (the ads one was kept on) and probably the theme wasn't switched as well.

    I realize that this might not be possible on a live site but we'll need to check it anyway and we might also need to perform some more "drastic" troubleshooting that might affect live site performance/stability temporarily.

    In that case, it would be best if we could use a staging site (that'd be a copy of a live one). Fortunately, a WP Engine provides a simple way to create such a staging site soul could you please create it?

    Once it's done, first make sure that the issue does also happen there and then grant us a support access to that staging site. We'll then be able to perform all the necessary test on it without affecting the live one.

    Let me know, please, once it's ready and the access to it is granted and we'll proceed with troubleshooting this.

    Best regards,

  • Adam Czajczyk

    Hello Binti Cuater Ora

    I just got some additional feedback from our developers and was able to fix that on your site anyway. Apparently, in some cases Smush auto-smushing option will not work in "async" mode on WPEngine.

    That said, I've added a

    define( 'WP_SMUSH_ASYNC', false);

    line to the wp-config.php file of your site to turn off the asynchronous mode and it's not working fine. I tested it by uploading two images to your Media Library (I removed them already) and they were both nicely smushed upon upload automatically.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.