Smush not smushing all photos

After enabling "Smush my original full-size images", Hummingbird is still recommending to compress images, like:
Compressing http://www.wasa****.com/wp-content/uploads/2017/10/cover-2-3.jpg could save 276.2KiB (35% reduction).

  • Nastia

    Hello Ben

    I hope you are doing well!

    I've visited your site and looks like the Super-smush option is not enabled. Please navigate to Media > WP Smush and enable it

    Once it is enabled, please run again Bulk Smush option.

    Just in case, you can enable "Make a copy of my full size images" it will keep a copy of the original images. so if you are not satisfied with compression you can restore the original image back. Please note this will increase the size of your uploads folder.

    Let us know how it went!

    Kind regards,
    Nastia