Smush on upload not working

I have Smush on upload enabled, but when I upload an image it doesn't get smushed automatically like it should. I have to either manualy smush it, or use the Bulk smush.

  • Adam Czajczyk

    Hello Zach

    I hope you're well today and thank you for your question!

    I checked the site and I can see the issue there. I took a look at the current debug.log and site configuration (wp-config.php file, .htaccess, folder permissions etc) but there seems to be nothing "unusual" here as well. There's also no errors in browser console. The bottom line is: it looks like either that automatic smushing wasn't triggered at all or was "intercepted"/"stopped" at server level.

    I've reported this to our developers and they'll look into it directly then. Please keep an eye on this thread for further questions/informations/more details from us (please note: developers' response time might be a bit longer than ours here on support forum as they deal with a lot of complex issues at the same time).

    Kind regards,
    Adam

  • Lindeni Mahlalela

    Hello Zach

    I hope you are doing great today. I am sorry for the delayed response from our side and thank you for your patience.

    I had a chance to look at your setup but I couldn't access your WordPress admin because support access has expired. Would you please re-enable support access or provide WordPress admin login details via our secure contact form, in the contact form choose "I have a different question" then include "Attn: Lindeni Mahlalela" in the subject and include your WordPress login username and password in the Message box along with a link to this thread for reference.

    I was able to access the WordPress install file to check the debug and error logs and found that there are a couple of issues that might be problematic in any setup.

    1. The PHP version and MySQL Server version seem to be of old age as a result, the current WordPress version is complainging about the underlying PHP and MySQL extentions, I see this on the lines that look like this:

    PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /path/to/wp-db.php

    This might be a small issue between the current WordPress version and the PHP version. Even though WordPress tries to be compatible with older versions of PHP but some plugins may not be as friendly as WordPress so I think it is about time to upgrade to a newer PHP + MySQL version.

    2. The database user gets disconnected due to some MySQL connection limits, it seems the user reaches the max allowed simultaneous connections at some point. I see that from this line:

    PHP Warning: mysqli_real_connect(): (42XXX/12XX): User <MUSQL_USER> already has more than 'max_user_connections' active connections in /path/to/wp-db.php

    And

    WordPress database error Lost connection to MySQL server during query for query SELECT ...

    All the above errors relate to WordPress core and PHP or MySQL related issues but they do affect these plugins according to the logs:

    System Plugin by GoDaddy - receiving too many connection errors, I think this is due to the point number 2 above.
    Hustle by WPMU DEV - also gets disconnected due to the issue number 2 above

    Other plugins and your active theme have unrelated warnings. I strongly suggest you try to upgrade your PHP version unless there is a serious reason why you should not like when you have an important plugin that is not compatible with latest PHP and MySQL versions, if there is no such plugin then please upgrade. Here is how to change PHP Version in GoDaddy, once you have done the change test to see if your sites load fine, if they don't load then change to another PHP version or revert back to current one.

    With regards to the reported issue, I do not see any entries in the logs relating to Smush and unfortunately I could not check on your WordPress admin as support access has expired, please enable support access or send login details using our secure contact form as requested above, once we have access we will continue to test but for now try the PHP upgrade.

    I hope this makes sense and hope to hear back from you soon.

    Have a nice day.
    Lindeni