[Smush Pro] After optimizing images it disappeared

All my site's images disappeared after optimizing images with Smush Pro and Smush CDN. All images show 404 error and I can't see any images in Media:

https://monosnap.com/file/2XhzmpZTv2yqQEPQaxDhXQNq6AChxs

  • Nebu John
    • Staff

    Hi Berkley,

    Hope you are doing good today.

    I am really sorry about the inconveniences you are having with regards to using our Snapshot Pro plugin and I hope we resolve it soon.

    I wasn't able to access the WordPress wp-admin with the credentials you shared, wouldn't you mind, please update the credentials and send to us?

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Nebu John"

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    - Link back to this thread for reference

    Also please update us here when you have finished restoring a backup.

    Kind Regards,
    Nebu John

  • Nebu John
    • Staff

    Hello Berkley,

    Are you sure you have restored your site?

    I could see that Smush is enabled and images are still missing in the media library. Further, I deactivated Smush Pro and try uploading a new image file, which is also facing the same issue. However, to further investigate this, we will have to recreate the issue and debug.

    Please restore a backup of the site where media library is loading fine and let us know here.

    Kind Regards,
    Nebu John

  • Nebu John
    • Staff

    Hi Berkley,

    Have you reset the credentials after the restore? I am not being able to login with the credentials you provided. :slight_smile: Please make sure you are not making any changes other than resetting the credentials.

    Please update us here when you have done with resetting credentials.

    Kind Regards,
    Nebu John

  • Nebu John
    • Staff

    Hi there,

    Hope you are doing good today.

    On further investigating this issue, I could see that some of your plugins are outdated and that includes Smush Pro. I appreciate if you could update the outdated plugins and theme before we further debug the issue.

    Also, I could see that the FTP access you provided is without write permission. We will need to enable debug mode to resolve this issue. Can you provide us FTP access with write permission? Let us know if this is possible and we will provide you a safe way to share access details with us.

    Lastly, can you provide us with the main admin login credentials? If not, provide the user that you have shared, the permission to access the WPMU DEV Plugin. You can do this by going to Dashboard >> WPMU DEV >> Settings >> Permission.

    Kind Regards,
    Nebu John

  • Predrag Dubajic
    • Support

    Hi Berkley,

    Apologies that this has taken this long, it seems that the issue is caused by the WebP Express rules added to your .htaccess file inside wp-content folder.
    Do you know which plugin has added this code to your site because I don't see any plugins with a similar name?

    After I removed the code the images started working fine and after I restored those rules it didn't break images again and they continued working properly.
    So it should be fine now but if you do encounter issues again try removing that .htaccess file.

    And please let us know if you know where this is added from so we could do some further tests on our end.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.