[Smush Pro] API Curl Error 28

This error is occuring..

[08-May-2019 16:45:49 UTC] [WPMUDEV API Error] 4.7.1 | cURL error 28: Operation timed out after 15004 milliseconds with 0 bytes received ((unknown URL) [500])

  • Dimitris
    • Support Star

    Hello frank_gomez

    1) Are you getting this error in other sites as well? If so, is there a pattern between these sites? Like hosted in the same server? Please advise!

    Keep in mind that this option is actually re-authenticates your connection with our premium APIs, instead of logging out and logging in to WPMUDEV Dashboard plugin.

    2) As I said above, I guessed that the error comes up during the Bulk Smush operation. Is this true? Is there anything broken in Smush or are you getting this message only in the debug file? The specific message was logged at 08-May-2019 so if you don’t have any recent messages like that, then there’s nothing to worry about as this could have been just a small glitch.

    Thank you,

    Dimitris

  • Nastia
    • Support Rock Star

    Hello frank_gomez

    Hope you’re doing well!

    Please whitelist the following IPs on your hosting end:

    66.135.60.59

    66.135.49.214

    66.135.60.64

    165.227.66.214

    192.241.140.159

    104.236.132.222

    192.241.148.185

    45.55.78.242

    34.196.51.17

    Also please make sure the WPMU DEV Dashboard latest version is installed.

    Then, please increase the max_execution_time, by adding the following like to the php.ini file:

    max_execution_time = 300

    Please see other ways to increase max_execution_time value in this post:

    How to Increase the Maximum Upload and PHP Memory Limit in WordPress

    If the issue still persists, would you please grant access to your site so we could have a closer look at the issue? You can grant access from WPMU DEV > Support

    Please let us know when you do!

    Kind regards,

    Nastia

  • frank_gomez
    • Recruit

    That is unacceptable because it would risk affecting the server negatively. I’ve checked many sites and the common thread is that the site with the most pictures are throwing this error. I STRONGLY recommend that you edit the plugin so that it does its work in bursts so that it doesn’t routinely exceed PHP memory limits. I’ve increased my limit from 30 to 90 seconds. BUT 300 is not OK

  • Dimitris
    • Support Star

    Hello there frank_gomez,

    hope you’re doing well today!

    That was a bit too high indeed. Generally, a max_execution_time of 120 or 150 can handle even the most demanding processes though.

    Even with a value of 90sec though, and the white-listed IPs, are you still experiencing the aforementioned issue? Please advise!

    If so, please try to add the following line in the wp-config.php file, just above the /* That’s all, stop editing! Happy blogging. */ comment:

    define('WP_SMUSH_API_TIMEOUT', 300);

    If you’re still having the same issue, please access your server via (S)FTP, edit the wp-config.php file, find a line like

    define('WP_DEBUG', false);

    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That’s all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set('log_errors', 1);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);
    // WPMU DEV API debuggers
    define('WPMUDEV_API_DEBUG', true);
    define('WPMUDEV_API_DEBUG_ALL', true);

    When you’re done, try to bulk smush some images once again until the error comes up again.

    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If the size of the text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.

    Reference: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Warm regards,

    Dimitris

  • Pawel
    • Staff

    Hello @frank_gomez!

    Thank you for sharing the debug.log – I’ve checkied it but besides some harmless notices and warnings there’s nothing else there that would explain the error you’re experienceing.

    Would you mind sharing access details to the site so we can access the filesystem and debug the issue further?

    Note: Please don’t leave your login details in this ticket as this is a public forum and anyone will be able to see them.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    NOTE: Don’t change selected topic in the dropdown, just leave it at “I have a different question”.

    Subject: “Attn: Pawel Pela

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Please reply here after you send in the credentials.

    Kind regards,

    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.