[Smush Pro] Broken images after enbling CDN

Hello,

I installed Smush Pro on my website and enabled CDN, however as soon as I had done that a lot of images on the website had 404 errors. We do not have any cache clearing plugins on the website so we tried clearing server cache, but we had no luck with that. I tried disabling and enabling the CDN feature and that did not work either. Could you help with a solution to this problem and with the reason why this happens?

Thanks!

  • Kris
    • Support

    Hi Iurii

    Hope you are doing good today.

    To investigate this more I will need below data to take a closer look on this.

    Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is “I have a different question” and:

    – Mark to my attention: ATTN: Kris Tomczyk

    – Site access (login url / username / password)

    – FTP credentials (host / username / password / port)

    – Link back to this thread

    Please don’t share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    Please confirm here in thread that you have sent that message.

    Kind Regards,

    Kris

  • Iurii
    • New Recruit

    Hello, thank you for your reply. Unfortunately, I can't send the data you required above, it is confidential. Is there any way we can arrange a call or screenshare session to try and fix this? I also attached screenshots with the configuration of the plugin. Lazy load is not activated and the images have 404 errors when CDN is enabled.

  • Kris
    • Support

    Hi Iurii

    Unfortunately, I can’t send the data you required above, it is confidential. Is there any way we can arrange a call or screenshare session to try and fix this

    I’m afriad without access to site and ftp we will be not able to review this issue and check what plugins are used, what theme etc. We and our developer need to be logged in to site to enable CDN, check page source and see what is going on with source of those images. There is also many other things to check.

    I can only suggest to use our live chat here https://premium.wpmudev.org/hub/support/#wpmud-chat-pre-survey-modal and share with our agent this ticket url. On chat session you can also provide us with site and ftp details which are secure with us and we could try to review issue during chat session. However if during chat session problem will be not solve we will need to back to the source, which is here and continue conversation on forum platform.

    We ensure that your data is safe with us so you could follow my guide here:

    https://premium.wpmudev.org/forums/topic/smush-pro-broken-images-after-enbling-cdn#post-1417899

    and send data via our secure form :slight_smile:

    Kind Regards,

    Kris

  • Nithin
    • Support Wizard

    Hi Iurii,

    On checking further this looks more like Smush API isn’t able to access the website, this is a quite common scenario to occur when the Smush API is blocked.

    Could you please double-check whether Smush CDN loads fine once you disable the web protection enabled? Please do make sure to clear the browser cache before testing.

    If you still notice anomalies, please do check whether with your hosting provider whether hostname of the Smush API is whitelisted in the server-side.

    http://smushpro.wpmudev.org/

    Please do let us know how that goes so that we could check further if needed.

    Best Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.