[Smush Pro] Bulk Smush not working

When trying to do bulk smush, the spinner stays spinning and the progress stays at 0% even after 4/5 hours.

  • Adam Czajczyk
    • Support Gorilla

    Hello Sandhya

    I hope you're well today and thank you for your question!

    This suggests that most likely there's a conflict with either the theme or some other plugin. In such case the thing to start with would be a full conflict test. Could you perform such test please?

    To do that:
    - switch the site temporarily to the "Twenty Nineteen" theme
    - switch off all the plugins except from Smush and see if the bulk smushing is working then

    If it does, stop it and start enabling plugins back one by one each time checking if bulk smushing is still working - until it stops and you know that the last enabled plugin (or the theme if you already went back through all the plugins) is causing the conflict. Let me know about it please and we'll taken it over from there.

    If the conflict test doesn't show anything, I'll need to take a closer look so in such case please enable support access to the site. To do so, please go to the "WPMU DEV -> Support -> Support Access" page and click on "Grant support access" button there, then let me know here once it's done.

    Best regards,
    Adam

  • Sandhya
    • New Recruit

    Thanks. I was able to get things to work by deactivating some plugins. Now I can see that they smush some images. But it invariable hangs after smushing around 150 to 200 images. Also, I get lot of errors like the one below.

    DSCF0156%2841%29.jpgCould not find /home/mycook9/public_html/wp-content/uploads/2011/04/DSCF0156%2841%29-150x150.jpg

    But when I go to cpanel, I can see this file there. Not sure why the smush stalls or throws these errors.

    Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello Sandhya

    Thank you for getting back to me.

    Thanks. I was able to get things to work by deactivating some plugins.

    Are you able to tell me which plugins these are? Usually it's just one plugin that's conflicting so it's a matter of deactivating and activating plugins back one by one to identify the specific one. Knowing about it could help us a lot in providing a "compatibility fix" :slight_smile:

    But it invariable hangs after smushing around 150 to 200 images.

    Would you mind enabling support access to the site so I could take a look? You can do it by going to the "WPMU DEV -> Support -> Support Access" page and clicking on "Grant support acces" button there, just let me know here once it's done.

    Also, I get lot of errors like the one below.

    DSCF0156%2841%29.jpgCould not find /home/mycook9/public_html/wp-content/uploads/2011/04/DSCF0156%2841%29-150x150.jpg

    But when I go to cpanel, I can see this file there. Not sure why the smush stalls or throws these errors.

    This might be related to why Smush "stalls" - if there's too many of these errors. They are related to file names. It's not recommended to use spaces (blanks) and special characters in file names and these files seem to use them.

    To be exact: this file name "DSCF0156%2841%29.jpg" translates to "DSCF0156(41).jpg" and that's perfectly fine in that latter form. The former one looks like "url encoded" version so that suggests some issues with character encoding that makes it impossible to read the file.

    You have checked these files via cPanel. Do you see them there in that first or second form - so e.g. as "DSCF0156%2841%29.jpg" or "DSCF0156(41).jpg"?

    When you go to Media Library and check URL of the image directly there, what does it show?

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.