SMUSH PRO CAUSING TWO ISSUES...

Hello!
Re: WP Smush Pro
1) Website Load Time is Degrading. Grade 'E' that was previously Grade 'A'.
Pasted info from GT Metrix:
Combine images using CSS sprites
E (52)
IMAGES HIGH
What's this mean?
The following images served from smushcdn.com should be combined into as few images as possible using CSS sprites.

https://592306.smushcdn.com/809178/wp-content/uploads/2013/04/oldsoul-metalworks-steel-fx-patinas-dyes1-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2014/03/FREE-SHIPPING-COUPON-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2014/06/24-HRS.-AFTER-3-APPLICATIONS-OF-COPPER-VERDE-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2018/06/Customer-Comments-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2018/10/POINTS-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2018/12/featured-artists-60x60.jpg?lossy=1&strip=1&webp=1
https://592306.smushcdn.com/809178/wp-content/uploads/2019/03/MARCH-MAYHEM-SALE-FINAL-BEST-everglow-60x60.jpg?lossy=1&strip=1&webp=1
2) Images below product Hero Image have been "Smushed" too much, rendering "Hover/Enlarge" of those images ineffective.
I have a couple of screenshots:

Looking forward to your input and/or advice.
Thanks!
Bill

  • Nithin
    • Support Wizard

    Hi BILL,

    Hope you are doing good today. :slight_smile:

    1) Website Load Time is Degrading. Grade 'E' that was previously Grade 'A'.
    Pasted info from GT Metrix:
    Combine images using CSS sprites
    E (52)
    IMAGES HIGH
    What's this mean?

    Seems like support access to your website wasn't enabled, so I wasn't able to give a closer look. Do you get the same issue when Smush CDN is disabled?

    The "Combine images using CSS sprites" message occurs if your theme is using too many sprites instead of a single sprite. Smush CDN, in general, shouldn't be generating such issue, however, it's tough to say without giving a closer look at the dashboard side.

    2) Images below product Hero Image have been "Smushed" too much, rendering "Hover/Enlarge" of those images ineffective.

    I'm afraid, I'm not sure which exact images you are having an issue with hover/enlarge issue. Is that the images listed under "Featured Products"?

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • BILL
    • WPMU DEV Initiate

    Access Granted. It's the Hero Image for Each Product in All Categories. Under the Hero Image, there are usually 4-6 "supporting images", which further represent what the individual product will do.
    (Patinas & Dyes for Metal, mostly steel).
    I'll grab a screenshot, but the hover/enlarge 'fail' won't show up unless I do a video screen capture.
    Would you like me to do that?
    Bill

  • BILL
    • WPMU DEV Initiate

    I may have found the solution to my smushed images that are now too small:
    https://wordpress.org/plugins/imsanity/#description

    FEATURES
    Automatically scales large image uploads to a more “sane” size
    Bulk-resize feature to selectively resize existing images
    Allows configuration of max width/height and jpg quality

    Optionally converts BMP files to JPG so image can be scaled
    Once enabled, Imsanity requires no actions on the part of the user
    Uses WordPress built-in image scaling functions

    Your opinion?
    Bill

  • Nithin
    • Support Wizard

    Hi BILL,

    Sorry for the delay in getting back to you. We reply to tickets based on queue order so that all the member queries are looked upon equally.

    I checked the query regarding the initial screenshot you have shared, and I ran a new scan, and it seems like the issue is resolved?

    I'll grab a screenshot, but the hover/enlarge 'fail' won't show up unless I do a video screen capture.
    Would you like me to do that?

    I quickly disabled the Smush CDN, and checked whether I could notice the hover/enlarge feature in your homepage images. But, I wasn't able to notice it. I'm afraid, maybe, I'm checking the wrong page, or I'm missing something. Have re-activated the CDN back.

    Could you please advise what's being missed, so that this could be looked upon closely? A screenshot would be helpful so that we could have a better idea of which exact image should be looked upon.

    Regards,
    Nithin

  • BILL
    • WPMU DEV Initiate

    Hello Nithin,
    I've been working on this for several days. I've found that SmushPro wasn't the problem, at least not the whole problem. Most of the problem was due to me uploading images that were too small.
    I found a workaround plugin that overrides the theme's hover/enlarge characteristics, and happy to report that it's working 10X better than it ever has!
    Thank you very much for helping me sort this issue out.
    Regards,
    Bill
    :sunglasses:

  • Nithin
    • Support Wizard

    Hi BILL,

    Sorry to hear that the update didn't go well in your website side. Seems like you have reverted to version 3.2.1. I could notice your website is hosted on WP Engine. Is it possible to set up a staging website where we could further test this out by updating the Smush plugin and have a better idea regarding what could be causing the issue?

    Once you have the staging site, please do enable support access to the staging website so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day ahead:slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi BILL,

    Unfortunately, the support access isn't working in my side when checked. I'm getting the following message, which could occur if the support access got expired etc
    This is an invalid access token. Please ask the user to grant access.

    Could you please send us your websites credentials, so that we could give a closer look.

    You can send credentials via our contact email contact@wpmudev.org

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -SFTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.