[Smush Pro] CDN Activation

I cannot seem to get the CDN to activate on my site. Every time I go to activate it, it either doesn't finish loading, or just tells me that it needs to be activated. I was wondering what a fix is for this, because I'd like to use the CDN network with Smush. Thank you,

  • Ash
    • WordPress Hacker

    Hello Sean

    There might be an error produced at the back end. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );


    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now try to activate CDN again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    If there is no debug log file generated, would you please enable support access so that I can check? Please follow this article to enable support access: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Have a nice day!


  • Ash
    • WordPress Hacker

    Hello Sean

    Did you try enabling debug log? I can see on the console, that there is a 500 internal server error, which means an error is produced.

    Please let me know about debug log. If you already tried and no debug log file is created, please consult with your host and ask the server error log. That will show us what the error is while activating the CDN within Smush.

    Have a nice day!


  • Nithin
    • Support Wizard

    Hi Sean,

    Please use Google Drive, Dropbox etc to share the debug log. I gave a quick look at your website via support access, and I could the Smush CDN is activated at the moment, and it loading fine.

    For example, if I got the following page:

    The images are served via Smush CDN.

    However, there are carousel slider images in the homepage, where the CDN isn't working. I suppose you notice the issue mostly with the images on the homepage, right?

    The images listed under "Places to Buy Fragrances Search Amazon" are loaded via Amazon URL/CDN, so there isn't much that could be done for images served from a different server.

    For images loaded via carousel, I could see it should have worked but that isn't the case. Could you please point out where exactly in the dashboard the carousel slider is configured?

    That's the slider images listed under "Latest in Men's Fragrances", "Ladies Perfume Posts" etc Is that settings part of the theme or a plugin?

    A screenshot would also be helpful so that we could give a closer look, and see what's being missed.

    Please do let us know so that we could help get you sorted asap. Have a great weekend ahead. :slight_smile:


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.