[Smush Pro] CDN appears inactive in Smush Pro

I'm trying to activate the CDN with Smush Pro; however, I am having issues. When I go into the CDN section of Smush Pro it states that "CDN is not yet active. Configure your settings below and click Activate." When I press the "Save and Activate" button, the button changes to "Activating CDN" and just spins. I've left the web browser window open for hours and the button just spins.

  • Kris
    • Support

    Hi Sean Bowen

    Hope you are doing good today.

    This issue could be a plugin conflict. Would you please run a conflict test? Please deactivate all plugins except Smush and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. If there is no positive result, switch to default WordPress theme like 2017 and see if it works.

    Before this test I recommend full site backup.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Also before you run this conflict can you add this code to your wp-config.php file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    also delete (if exist)
    define('WP_DEBUG', false);

    The line should be placed above the "/* That's all, stop editing! Happy blogging. */"

    This will generate in the /wp-content/ folder a debug.log file when you will try to activate CDN again.
    Please attach the debug.log in your next reply in txt format file, so that we could take a closer look on this issue.

    Kind Regards,
    Kris

  • Sean Bowen
    • New Recruit

    Hey Kris, while waiting on your response I tried some troubleshooting of my own. I deactivated the Smush Pro plugin and reactivated it. When I reactivated I received an error. I searched the forums for the error message and came across this thread. Before I proceed with your suggested troubleshooting, does this new information change anything? Here's the thread in question:

    https://premium.wpmudev.org/forums/topic/smush-cdn-not-activating

    Thanks for your assistance.

  • Kris
    • Support

    Hi Sean Bowen

    I made full review of above ticket and that one was related to cache on user side. If you're able to clear your site cache and any cache on host side (if any exist) and try to activate Smush and CDN again.

    If this does not help please let us know about the results of above test.

    Kind Regards,
    Kris

  • Sean Bowen
    • New Recruit

    I started working on the conflict testing this morning. I copied my site to a staging server and started to edit the wp-config.php file. I don't see the "/* That's all, stop editing! Happy blogging. */" line to place the other code above. I've searched with no luck. Where should I place the code in the file?

  • Sean Bowen
    • New Recruit

    Good morning Kris !

    I started the plugin conflict testing this morning on my staging site at 9:50am CT. I disabled all the plugins and was able to successfully "save & activate" the CDN within Smush Pro. Then I went one by one through each of my other plugins. I would activate the plugin, then go back into the CDN with Smush Pro and try to "save & activate." Each time I was successful. I was able to reactivate all my plugins and still able "save & activate" the Smush Pro CDN on my staging site.

    Next, I deactivate the Smush Pro CDN, reactivate it, the was able to successfully "save & activate" the CDN.

    I've attached the debug log file. I don't know if this will help as I'm still receiving the "exponential backoff " error message when I try to activate Smush Pro CDN on my production site.

    Thanks for your assistance.

  • Kris
    • Support

    Hi Sean Bowen

    This is very odd case. However I see some error in debug.log. Before I pass this to developers and ask you for site and ftp access could you reinstall Smush on live site and before you active CDN there disable all plugins first?

    Before that make full site backup and proceed above when traffic on site is low?

    Kind Regards,
    Kris

  • Sean Bowen
    • New Recruit

    I think I have this fixed. I had to do the following:

    1. Disable all settings within Smush Pro.
    2. Ensure that all settings would be deleted when uninstalling Smush Pro.
    3. Deactivate Smush Pro.
    4. Uninstall Smush Pro.
    5. Delete/empty all caches.
    6. Reinstall Smush Pro.
    7. Activate Smush Pro.

    Boom! I was able to enable the CDN and "save & activate" the CDN settings with no issues.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.