smush pro - images not downloading

I have to deactivate smush pro in order to download media files otherwise they will not load properly - then reactivate the plug-in to smush them.

    Dimitris

    Hey there Michelle,

    hope you're doing good and thanks for reaching us!

    Could you please elaborate a bit more with me on this?
    Smush shouldn't involve in any of these procedures as it only lowers down the filesize of media files.
    How do you try to download these media files? Are you using a plugin for this?

    Could you also grant us with support access to your website to see this issue in action. I may need some post and/or media URL in order to not miss anything, so please describe thoroughly your issue and the exact steps you're following.
    For more details on granting us access, please have a quick read here https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris

    Dimitris

    Hey there Michelle,

    as I don't see a connected website with this thread, could you please update Smush Pro to the latest version, if not already.
    We could then use some debug information if this continues. Simply access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by uploading an image in Media Library while Smush is activated. By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply.

    Looking forward for your results on this!
    Warm regards,
    Dimitris