[Smush Pro] Is My Site Not Showing SMUSHed Images?

Hello!

I was trying to rectify some issues highlighted by Hummingbird and GTMatrix about site speed and noticed that both had said that my site does not seem to be serving the optimized images that SMUSH Pro is set up to do.

Is there a way I can double check on this? SMUSH is set to optimize all images on upload and delivery Lazy Loading, but both Hummingbird and GTMatrix recommend enabling Lazy Load *and* seem to note the site is serving the original image files instead of the optimized one.

Thanks!

  • Nithin
    • Support Wizard

    Hi Casey ,

    I could still notice there are still many images pending for Smush. Am I missing anything?

    There are images in the Media Library which still require smushing. Please do note that the “Automatic compression” option will only smush newly uploaded images after the option was enabled.

    For older images which still require compression, you can use the Bulk Smush feature. Please go to Smush Pro > Bulk Smush, and click the “Bulk Smush Now” button to ensure all the pending images are smushed.

    Also, it seems like all the images are served via WP Engine CDN. Could you please temporarily disable the CDN, and once the Bulk Smush is finished, please clear the WP Engine Cache, and re-run a new performance test to see how it goes.

    Please do advise if I have missed out anything. Looking forward to your response. Have a nice day ahead.

    Regards,
    Nithin

    • Casey
      • Flash Drive

      Hey Nithin – that’s a separate issue. I had to use WP-Engine’s “LargeFS” service for my images which uploads them onto an Amazon S3 server, but the images uploaded before SMUSH was installed can’t be optimized right now.

      The issue is when you do a Hummingbird speed test, images that *should* be smushed because they were uploaded later still seem to be showing up on the page as full-res files.

      I was running the built-in WPMUDEV CDN but have turned that off yesterday, so it should all be working now.

      Thanks!

  • Nithin
    • Support Wizard

    Hi Casey ,

    The issue is when you do a Hummingbird speed test, images that *should* be smushed because they were uploaded later still seem to be showing up on the page as full-res files.

    I suppose the images listed under “Efficiently encode images” in the Performance results, right?

    If yes, the images listed in there could further be optimized by enabling “Super Smush” option in the Smush Pro plugin settings, under Smush Pro > Bulk Smush > Super Smush.

    If you only want to run super smush on selected images listed, then you could do that by clicking the “Smush” button which should be listed once you click the images under Media > Library.

    Could you please check whether running super smush on these listed images resolves the issue or not? However, please do note that since the images are uploaded using “LargeFS” service, cannot say for sure whether running a Super Smush would sync the changes to the images present in the CDN.

    You might have to delete, and re-upload the images with “Super Smush” enabled to double-check whether it resolves the issue or not.

    Please let us know how that goes. Have a nice day ahead.

    Regards,
    Nithin

    • Casey
      • Flash Drive

      That seems to be more along the lines of what I’m thinking of.

      All of the files on the front page right now were uploaded WELL after I set up SMUSH to auto-optimize everything on upload. It looks like the files being served have not been optimized at all.

      I run a very photo-heavy site (the total storage is around 15GB right now), so deleting and re-uploading is a pretty intensive process, so I’d like to try to make sure I have everything in order before I try to do something like that.

      Also, with the super-smush, are images noticeably altered on that? I’d just hate to have to turn off and on the bucket, wait for 15GB to upload, and then have to do it again if all the photos look blurry, ya know?

  • Nithin
    • Support Wizard

    Hi Casey ,

    I run a very photo-heavy site (the total storage is around 15GB right now), so deleting and re-uploading is a pretty intensive process, so I’d like to try to make sure I have everything in order before I try to do something like that.

    I suppose your concern is when running a Super Smush for all the 15 GB of image data? From the Page Speed results shared in the previous reply, only 4 images are listed in the screenshot that requires further compression.

    Instead of running Super Smush on all the images in the Media Library, you could just “Super Smush” only the 4 images listed which needs further compression to see how it goes.

    Once the “Super Smush” option is enabled in the plugin side, you should be able to Super Smush the images individually via Media > Library. For example:

    I suppose that would help better than running “Super Smush” feature on a 15 GB of data?

    Regarding the photos being blurry, it shouldn’t significantly reduce the quality of the issue, if you think that’s a concern, maybe you could just re-upload these 4 images again as a duplicate to see how the quality of the images goes once “Super Smush” is enabled?

    Once done, if you think the quality is good, you can “Super Smush” the actual 4 images individually which is used in your website.

    Would that help? Also in case you are looking to super smush all the images in your website, Smush Pro does comes with an option to bulk restore all the images in the Media Library too, which you can find under Smush Pro > Tools > Bulk Restore.

    However, would highly recommend taking a backup of the website before making any changes. Hope this clears your query. Please let us know if you need any further assistance.

    Kind Regards,
    Nithin

    • Casey
      • Flash Drive

      I think we’re getting closer —

      What I’m asking is — it looks like my site is rendering FULL sized images for a lot of these things — like the image that’s nearly 6MB on there is only used on the page as a thumbnail at the very bottom. And my SMUSH is set up to automatically resize files that are too big to the proper size. So I’m trying to figure out

      a). if something isn’t correctly configured on SMUSH
      b). if a plugin or theme conflict is stopping SMUSH from working properly or the site from displaying the right images

      I turned on the option in SMUSH to display any images that were improperly sized for their containers, and the only thing that gets highlighted on my frontpage is the logo.png.

      Can anyone make sense of this? Or am I kind of just going around in circles? Is this something I should take up with my host (they run the LargeFS service)?

      Thanks!

  • Nithin
    • Support Wizard

    Hi Casey ,

    it looks like my site is rendering FULL sized images for a lot of these things — like the image that’s nearly 6MB on there is only used on the page as a thumbnail at the very bottom. And my SMUSH is set up to automatically resize files that are too big to the proper size

    Sorry for the delay in getting back to you. What Smush does is optimize images based on the thumbnails registered by your theme and plugin. The plugin shouldn’t be performing any other actions other than compressing and optimizing the existing image size registered within your WordPress website.

    I’m not sure how LargeFS service works, so if you still think there is anything specific causing anomalies it would be better to double-check with the hosting provider too.

    a). if something isn’t correctly configured on SMUSH

    There shouldn’t be an issue with the current configuration done in the smush plugin side settings. The default settings should be fine, as stated if you want to smush the images further then you’ll have to enable the “Super Smush” option.

    b). if a plugin or theme conflict is stopping SMUSH from working properly or the site from displaying the right images

    Are there any instances where you could notice such issues? Google Page Speed only sees to list out “Efficiently encode images” which could be fixed once Super Smush is enabled.

    If you think you notice any anomalies or conflicts then please do point that out via screenshot or image links so that we could have a better idea.

    I turned on the option in SMUSH to display any images that were improperly sized for their containers, and the only thing that gets highlighted on my frontpage is the logo.png.

    I suppose you meant the “Image Resize Detection” option, which lists out the images in yellow border highlight?

    It seems like the support access to your website is not enabled at the moment, so I couldn’t check that further.

    Could you please update the Smush Pro plugin to the latest release, and enable support access so that we could check further regarding the mentioned option.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a good day ahead.

    Kind Regards,
    Nithin

  • Casey
    • Flash Drive

    I just re-enabled support access for you in case you wanted to take a look.

    In the audit, under efficiently encode images, there is the next-gen format issue you note but more concerning to me is the “compressing image quality” audit.

    For instance, in the current audit this image is listed:

    https://3q6jfk244bi51myw1n49at43-wpengine.netdna-ssl.com/wp-content/uploads/2019/07/Bennettville-and-Fantail-Lake-5.jpg

    It’s 6MB with a potential savings of 4.8MB. It is also enormous in dimension.

    In my SMUSH settings (just updated to the latest version), it is set to resize images to a max of 1500×1500, but this image being served is significantly larger than that … as are all the other images that are showing up on the audit.

    Based on my settings, an image like the one listed above shouldn’t be able to make it through without being resized and optimized, right?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.