[Smush Pro] Issue with odd code on website

Recently, I experienced a client's website displaying odd text/code. It appears that it would only display where there's currently an image. After, disabling the CDN option within Smush Pro, the issue was resolved.

Here's the link to the screenshot, https://cl.ly/75059f41196e.

Wondering why this has happened. Would love to know if I can't use the CDN on this particular website, if not, why.

  • Nithin
    • Support Wizard

    Hi Julius,

    Thanks for sharing a screenshot, that’s odd behaviour. Could I know whether you notice the same issue when you disable Smush Lazylaod feature?

    If yes, please try the following attached patch, and see how it goes. You’ll have to replace the given file under:

    /wp-content/plugins/wp-smush-pro/core/module/class-wp-smush-lazy-load.php

    If you still have issues even after that. Could you please check whether switching to a default WP theme also causes the same issue or not?

    Please do enable support access, if you still notice anomalies regarding the issues even after following the above steps.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Julius,

    Below are the different ways that I tried the settings for both CDN/Lazyload

    That’s odd behaviour. Did you also test by switching to a default theme like TwentyNinteen? Could I know on which plugin version do you notice the issue? As I could notice the current plugin version you have installed is 3.2.0.2. Any specific reason to not update the plugin to version 3.2.21?

    We would like to further troubleshoot the issue. Could you please update the plugin to the latest version, and enable support access so that we could check further?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day.

    Kind Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.