Smush Pro Lossy Compression Not Working

Hi. I installed Smush Pro on our website and initially only did a general Bulk Smush (lossy was not checked just to see how it would do as a first pass). I then ran page tests and decided to enable the lossy compression, except Smush is not going back and starting over again to do a lossy re-compress. The green progress bar is stuck in an almost complete state from the first bulk smush and has stopped at an error (see screen cap).

I have enabled Support Access for someone there to take a look. I would greatly appreciate any suggestions as to what might be done to solve the issue.

Thank you so much for your time,
Carolyn

  • Jude

    Hi there @Connect

    Can you take a backup and try reset the database as shown here ??

    delete_option('wp-smpro-sent-ids');
    delete_option('wp-smpro-bulk-sent');
    delete_option('wp-smpro-bulk-received');
    delete_option('wp-smpro-current-requests');
    delete_site_option('wp-smpro-current-requests');
    global $wpdb;
    $wpdb->query("DELETE FROM $wpdb->postmeta WHERE meta_key='wp-smpro-is-smushed' OR meta_key='wp-smpro-smush-data' OR meta_key LIKE '%wp-smpro-request%' ");

    You can either add that to a simple plugin, like at the end of "Hello Dolly" activate hello dolly and then it'll be reset, then deactivate hello dolly and re-send the request.

    Or you can add that in your functions.php (make sure to remove the code, before sending the request again, otherwise it'll just keep deleting the request).

    Hope that helps

    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.