Smush Pro not smushing images, rechecking them shows same number

Hello, I just purchased WP Smush Pro again today. For a little while, my credit card number was changed and the renewal couldn't renew so it (presumably) rerouted back to free version. I didn't realize it was not renewed and yesterday I attempted to smush the images and after waiting for the process to complete with no errors, a gtmetrix scan still indicates my images are not scaled and optimized (which it did not say this before I recently posted 2 posts with their featured images now displaying in my blog) I then clicked re-check images and it then displayed the same number of images needing optimization as before I ran the smushing process. I noticed this same occurrence even after I re-purchased the WP Smush Pro, except it actually read-out about 6 images that were skipped, I suspected that meant it was working but to no avail. I suspect that the plugin did nothing at all but said it was processing the entire time. I would greatly appreciate any assistance with this issue. Thank you very much and have a marvelous day!

  • Nithin

    Hi Alexander,

    Hope you are doing good today. :slight_smile:

    I checked your website in gtmetrix, and it seems like 2 of the images are loaded form the theme folder, and one from plugin folder. WP Smush Pro doesn't have any control over images loaded form these folder, the plugin can only smush images in the Media Library(ie Media > Library). You'll have to manually compress these images, and re-upload in back to the folder either using a tool like Photoshop, or compress using WP Smush Pro by uploading in Media library, and downloading it back, and then replace these compressed images.

    websiteurl/wp-content/plugins/accesspress-social-icons/icon-sets/png/set1/instagram.png
    websiteurl/wp-content/themes/luminescence-lite/images/backgrounds/background1.jpg
    websiteurl.com/wp-content/themes/luminescence-lite/images/post-shadow.png

    The other two images as shown in gtmetrix, needs to be compressed, and resized to fit the content width of your theme. At the moment, these images are larger than the content width of your theme, and hence it's being shown as not optimized.

    You might find this thread helpful on how to compress, and resize the image using WP Smush Pro:
    https://premium.wpmudev.org/forums/topic/resize-images#post-1133838

    If you still have issues, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regrads,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.