Smush Pro server is not reachable

hi,
getting the message
"Oh Snap! Seems like Smush Pro server is not reachable, you can try back in some time."

currently on WPengine without any DNS pointed yet (not staging),
was just wondering if this might be an issue or if its "Smush Pro"
also on their new php 5.5 platform which apparently has some issues with login plugins they claim.

kind regards.

  • amused
    • friend of Bill. W.

    ok thanks a lot @Patrick
    i unchecked wpengine cdn,
    also unchecked their "Object caching" and cleared cache.

    if my rotten brains serves me right i remember using "WP Smush Pro" on wpengine because WP Smush Pro is pretty new so i am thinking that the only thing different is i very recently switched to their new "php 5.5 platform" as mentioned above.

    just mentioning this because i am trying to troubleshoot what may have changed.
    and apparently from what i gather its not just php 5.5 but also incorporates other improvements as well. each wpengine "install" actually has to be requested and handled manually by them.

    i could be way off but as i mentioned i am just trying to give as much feed back to troubleshoot as possible.

    what else could cause this ?

    kind regards.

    oh, @Patrick there was also a previous thread that you most kindly helped me with previously for a test site i had, but that site is now deleted and you referred me to a site at that point in time but i cannot recall which it is and would love to view it again. could you please email me so i can visit the site you referred me to again please ?

  • Patrick
    • Support Monkey

    Hi again @Randall

    I hope you're well today!

    Let's try something that appears to have worked on other WP-Engine installs: enable the CDN and add the WP Smush Pro IP address to the CDN whitelist.

    The IP is 66.135.55.161

    Here's a handy article for whitelisting IPs:
    http://support.maxcdn.com/how-to-whitelist-your-server-to-use-the-api/

    As for the site I referred you to in a previous thread, can you provide a link to that thread, or a bit more information on the subject of the thread? I really have no clue there which site I may have referred you to. :wink:

    EDIT - On a test site that is not hosted at WP-Engine, I sent 20 images to be Smushed just before posting here. I just got the email telling me the smushing has completed, and have verified that on my site. So, at least we know the server is indeed reachable and the process is working. :slight_smile:

  • amused
    • friend of Bill. W.

    ok thanks but i believe wpengine live chat said i can't individually whitelist an ip on the cdn on my own. if u are certain this can be done, then i guess i can ask them about this again.

    they went ahead however on their end but still not luck.
    screenshot - shows one of their replies.

    based on the high popularity of the plugin they expressed interest in any support wpmudev can offer for other users on their platform.

    strange thing is that as i mentioned, i disabled cdn and cleared cache and "Object caching" from my wpengine dashboard.

  • Ash
    • WordPress Hacker

    Hello @Randall

    I hope you are well today.

    I have just talked to the developer and he will take a look.

    Would you please send him your admin login and ftp login?

    To send him details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Umesh Kumar
    Details: Send all required details (admin info and/or ftp details) with a link of this thread, so that I can track.
    Also post a note here once you send the info.

    Cheers
    Ash

  • Umesh Kumar
    • Code Wrangler

    Hi @Randall,

    I looked up the issue, we are using transient api to store the connection status, and the transient api is not seem to be working on your site.

    Can you please check with WPEngine, if they have something to do with transients not working for you?

    In case they need more info, I'm using set_transient function, but the function always returns false as it is not storing the value in DB.

    Thanks.

  • amused
    • friend of Bill. W.

    hi
    @Umesh Kumar
    sorry for the late reply,
    seems they have changed up their ticket system a bit and i eventually got a reply from them via email.

    here is what they have last said ;
    "We don't have a limitation on Transients, however we do clean out old ones. I think I was able to track down the root cause of this issue. After disabling the object cache and running a few of our reparative admin scripts, the plugin began to work properly. It seems as though the WP Smush Pro plugin was having an issue with how our Object caching works."

    i will try out different "installs" (what they refer to individual wp sites) and even create a new one and test again.

  • amused
    • friend of Bill. W.

    ok,
    i have tried on other installs as well as a new install specifically for this.

    same problem.
    ie. notice saying ;
    "Oh Snap! Seems like Smush Pro server is not reachable, you can try back in some time."

    i know "smush pro" is new to wpmudev,
    but its got such a large download from wordpress and wpengine is so popular for so long now,
    strange it seems this is unique to me,
    that why i tried on different installs and even a new one.

    i am very willing to assist in any way i can to get this sorted out for anyone wanting this on wpengine.

    just guide me accordingly.

    will also notify wpengine that the same thing is happening on existing and new installs and post feedback here.

    kind regards.
    RC.

  • Umesh Kumar
    • Code Wrangler

    Hi @amused,

    I'll check it again with object caching, because the plugin works fine with a number of sites on WPEngine but then it have issues on very few of them. So, definitely your help is appreciated in sorting this out.
    I'll use the WpEngine login you've sent to check the issue.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.