[Smush Pro] Smush Pro didn't smush all my images.

I have 30,000 photos to be smushed but only 7000 were smushed! Would you please help me to figure out why not all my images were smushed? https://monosnap.com/file/xkjIzxIQzVap7FGNSJTPqCwWv3bE0n

  • Nastia
    • Support Rock Star

    Hello Joni

    Hope you’re doing well!

    There is an error showing up during the Smush image compression:

    Image ID: No file data found in image meta

    This error means that an image is corrupted, somehow there are missing attachments. You can see the issue when editing an image; please enter the following URL, in your browser by changing yoursite.com to your domain name:

    yoursite.com/wp-admin/post.php?post=35750&action=edit

    This issue happens when there is no metadata, an image failed to be imported and/or there database table is corrupted. If the database table is corrupted, these can be fixed manually, only by editing the database entry, but there are plugins that could fix these broken entries.

    Please try the following plugin that is meant to fix database entry _wp_attachment_metadata meta field:

    https://wordpress.org/plugins/wow-media-library-fix/

    There are images on your site that still can be compressed besides the corrupted images. Please feel free to click on Bulk Smush button and let it finish optimizing the rest of 30.000 images. The Smush will skip the corrupted images and will continue optimizing the rest.

    Let us know how it went!

    Kind regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.