[Smush Pro] Smush Pro interfering with Essential Grid

Essential Grid is not displaying the Post feature image of a Post when displaying the post summary in mason format. Smush Version 3.2.2.1 Essential Grid Version 2.2.4.1 active on subsite only WordPress Version 5.2.2 Theme Pro Version 2.5.5.
With Smush Network Activated:
https://locoshots.com/wp-content/uploads/2019/07/smushnetworkactive.png
With Smush Network Deactived:
https://locoshots.com/wp-content/uploads/2019/07/smushnetworkdeactive.png
Nothing in error log regarding Smush interaction with EG.

  • Kris
    • Support

    Hi Bill

    I see that subsite firststateequine is under "Coming Soon!" mode and even after login as superadmin main site still display "Coming Soon!" message.

    Do we have your permission to deactivate this module?
    Also can you share urls to those pages which you share in above screenshots?

    Kind Regards,
    Kris

  • Nithin
    • Support Wizard

    Hi Bill,

    I'm afraid, I'm not sure whether I follow the exact issue. I logged into the dashboard and could notice Smush was already network activated in your website.

    And the images were loading fine in the mentioned page as shown in the following screenshot:

    Then checked whether it's due to the Smush CDN, so I went ahead, and enable Smush CDN network-wide, and still, I don't see any issues with images not loading as shown in your screenshot.

    I have deactivated Smush CDN for now. Since Smush Pro plugin was already enabled when accessing your website I haven't disabled it.

    Please do check, and advise if I'm missing anything specific regarding this so that we could check further if needed. Have a nice day ahead.

    Best Regards,
    Nithin

  • Bill
    • Somewhere in Between

    Hello,

    Please look now. While Smush may have appeared to be Network activated, it was activated on 1 subsite which in turn caused the settings panel to show on the Network Admin menu. I have disabled Smush on that single site and the settings option no longer show.

    I am sorry, when I Network Activate Smush from the main Network Administrator panel, I loose the images on the page above. When I turn it off, the images display again.

    I have the same result using various browsers and different devices.

    I will try to do a live chat and work with someone and hopefully I can show them what is happening.

  • Nithin
    • Support Wizard

    Hi Bill,

    Thanks for pointing that, I checked all other aspects like cache except checking regarding whether it was enabled in the main site.

    I could notice the issue when network activated, and the issue is related to Lazyload settings in Smush Pro. The Essential Grid plugin already has Lazyload enabled which is causing conflicts with the existing Lazyload settings of Smush Pro when enabled.

    I have added the page URL under the Exclusions list in the Lazyload settings of Smush Pro, and once done, the page does load fine.
    /gift-ideas/

    Do you have more than the mentioned page where Essential Grid is enabled? I checked exclusion of class would work or not but that doesn't seem to help much.

    In general, the latest version of Smush Pro should have support 3rd party lazyload plugins, but in case there are any conflicts adding the pages in the exclusion list would be the workaround.

    I have disabled the Smush Pro plugin since I have added the URL in the exclusion list the page should load fine if you enable the plugin again.

    I'm checking with the developer to see if there is any specific out of the box support that could be implemented within Smush Pro side regarding this, and will get back to you once I get further feedback asap.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Bill,

    I forgot to mention, that was the only page and site with the issue at this point.

    Then excluding the page URL which is already done should be enough in that case then. However, I have pinged the developer to see if there are any further improvements, and will keep you posted for any further feedback. Have a great weekend.

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.