Smush Pro takes too long and Hummingbird is slow

There is a small problem with wp smush pro. I though wp smush was supposed to be the king of image optimization. I takes too long to compress . And also with the hummingbird . To combine the css and javascript as well as html, it doesnt work well. So many files that need combining are listed but when i click save changes it says it has been saved but my site loaded at 16.6 seconds!!! please solve

  • Kasia Swiderska
    • Support nomad

    Hello Jason,

    I though wp smush was supposed to be the king of image optimization. I takes too long to compress

    Optimzed images will make your site load faster, but Smush has to have its time to process images - that time depends on how big are your images, how many thumbnails for each image is there and how many images you have. Smushing is done on our servers not on your site - so Smush has to send those images - that takes time.
    Smaller images will be smushed quicker.

    To combine the css and javascript as well as html, it doesnt work well. So many files that need combining are listed but when i click save changes it says it has been saved but my site loaded at 16.6 seconds!!! please solve

    Hummingbird minification only minifies CSS and JS files, it does not change HTML output. But would you mind allowing support access so we can check your site and see what is causing long load time?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Jason,

    Hope you are doing good today. :slight_smile:

    Please analyse my site and find out what is causing the speed issue on my site especially the back-end (wordpress dashboard). It would be of so much help if you could tell me how else i can speed up my site to the fullest . Also please disable minification in hummingbird for me , as this does not help at all. WP Rocket's minification is so much better.

    At the moment, reading your message you left for us in the dashboard, it seems like you only need to solve the issue related to having a slow WordPress dashboard. If you are considering making use of Hummingbird minification, please do let us know we would be guide you on configuring it.

    Regarding your WordPress dashboard being slow, I tested your website in Pingdom, and it seems like your server is taking too much time to respond, ie 2 seconds, which seems to be high. To rule out whether it's a plugin conflict, would recommend you to disable all the plugins, and check whether your dashboard speed improves, if not. It has to do with your host.

    I could also notice that you are using cache plugins in your system. One of the reasons to having a slow dashboard would be enabling Object cache, Could you please disable Memcached Settings, located under SuperCacher > Memcached Settings, and please check whether it makes any difference.

    I hope this helps. Please let us know how that goes, and advise if I had missed out anything. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.