[Smush Pro] WP Smush CDN for mapped domains

Hello,
We have about 80 websites on a WPMU and would like to benefit from the Smush Pro CDN.

When we develop a website, we use these URLs: https://www.magikweb.net/futurewebsite-com
And when they go live, we modify the site's URL to: https://www.futurewebsite.com

Everything is native (WPMU), there's no customizations, only the URL is changed and we point the DNS to the WordPress installation.

The CDN seems to apply to magikweb.net (root site) only.
That way, this site (subsite) works: https://www.magikweb.net/mclemieuxconferences-ca/
But not this one (other subsite): https://www.erictruchonphoto.com/

Is there a way (technical or not) to allow all sites' domain to access it?

  • Nithin
    • Support Wizard

    HI Vince,

    Sorry to hear about the issue, it should have worked fine, in general, is such setup too. However, could you please enable support access to your website, so that we could give a closer look at the dashboard side to have a better idea regarding what could be causing for Smush CDN to not work as intended in such workflow too.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Vince
    • Flash Drive

    We don't know if it's because support is trying something, but we noticed that WP Smush CDN is applied to an image on this subsite: https://www.ericperreault.ca/ (see the broken image)

    The image link is: https://697538.smushcdn.com/1091225/wp-content/uploads/sites/86/2018/11/slogan.jpg?size=1618x334&lossy=1&strip=1&webp=1
    Which results into an error: {"success":false,"data":"Error: CWebp was unable to optimise image, result:255 File: \/tmp\/smush_FFYm80"}

    Here is the original image: https://www.ericperreault.ca/wp-content/uploads/sites/86/2018/11/slogan.jpg

  • Nithin
    • Support Wizard

    Hi Vince,

    When we develop a website, we use these URLs: https://www.magikweb.net/futurewebsite-com
    And when they go live, we modify the site's URL to https://www.futurewebsite.com

    The CDN seems to apply to magikweb.net (root site) only.
    That way, this site (subsite) works: https://www.magikweb.net/mclemieuxconferences-ca/
    But not this one (other subsite): https://www.erictruchonphoto.com/

    I tried to check the reported subsites, but it doesn't seem like there is any such subsite with such an URL:
    https://www.magikweb.net/futurewebsite-com

    Regarding the following subsite:
    https://www.magikweb.net/mclemieuxconferences-ca/

    I could notice the website isn't mapped yet, so wasn't whether you would be comfortable with us changing the original URL to the mapped domain, or not too.

    However, the CDN seems to be loading fine without the mapped domain in the mentioned website.

    I checked other mapped domains in the website side and could notice Smush CDN does work fine without any issue. Please do note that at the moment, Smush CDN will only work for images present inside the img tag, that's for example:
    <img src="path-to-image">

    Smush CDN will skip images loaded via CSS, and such images won't be served via CDN. Making Smush CDN work for images added via CSS is a feature our team is working on to implement down the roadmap. Maybe those types of images you are noticing as not working?

    Checking the website:
    https://www.ericperreault.ca/

    Could notice the reported broken Smush CDN link, but it looks more like a cache issue. Even after disabling the Smush CDN the frontend was still loading the same broken Smush CDN link.

    Seems like the cache is related to the minified files, and it seems to be enabled in the subsite dashboard. Since support access doesn't allow to access the mapped domain dashboard, could you please disable Smush CDN, and clear both SG cache, and subsite-specific cache, and then check whether re-enabling Smush CDN makes any difference in making that image work?

    If you still have any mapped domains where Smush CDN isn't working, please do point that out, so that we could give a closer look, if needed.

    Please let us know how that goes, have a nice day ahead.

    Kind Regards,
    Nithin

  • Vince
    • Flash Drive

    Thank you Nithin for the follow-up!

    The https://www.magikweb.net/futurewebsite-com was just an example to show the URL format (https://www.magikweb.net/WEBSITEURL), it is not an actual website.

    For https://www.magikweb.net/mclemieuxconferences-ca/, you are correct, it's not mapped and it seems to work properly. (Good!) This was to show you that non-mapped sites do work. You may leave the URL as it is.

    You are correct about CSS, we thought it would apply to it as well. Thank you for the heads up.

    For https://www.ericperreault.ca/, when we are logged in (WP Backend), we don't have any caching (so people can edit their pages properly) and it still tries to load: https://697538.smushcdn.com/1091225/wp-content/uploads/sites/86/2018/11/slogan.jpg?lossy=1&strip=1&webp=1
    Which is the result of this: https://www.ericperreault.ca/wp-content/uploads/sites/86/2018/11/slogan.jpg (same URL as Smush':wink:
    We can view the image properly only when using the page builder (it skips WP Smush CDN).

    For further tests, is there a way to disable WP Smush CDN only on that site? I bet the image will show up afterward (after I re-empty the cache).

    The only other issue we've found is with Envira (see attached file). Reference: https://www.erictruchonphoto.com/
    Other than that, it works pretty well now that I know that it doesn't apply to CSS.

    Thank you for your patience and help! This CDN is easy to use and will save us from clients uploading crazy formats.

  • Nithin
    • Support Wizard

    Hi Vince,

    For https://www.ericperreault.ca/, when we are logged in (WP Backend), we don't have any caching (so people can edit their pages properly) and it still tries to load: https://697538.smushcdn.com/1091225/wp-content/uploads/sites/86/2018/11/slogan.jpg?lossy=1&strip=1&webp=1
    Which is the result of this: https://www.ericperreault.ca/wp-content/uploads/sites/86/2018/11/slogan.jpg (same URL as Smush':wink:
    We can view the image properly only when using the page builder (it skips WP Smush CDN).

    Sorry for the delay in getting back to you. Just to be clear, last time I accessed your site, I did a test by temporarily disabling the CDN, and the homepage was still loading the CDN URL when logged out, so there seems to be some cache working in your website to start with.

    I could notice there is minify cache generated from the following URL:
    https://www.ericperreault.ca/wp-content/cache/min/86/6f6f55edeeec17b4eab0773dfca6724f.css

    So there are chances the cache file might be interfering regarding this, the above would still apply even when logged in too. Could you please check whether there is an option to clear or purge the mentioned cache file to see whether it makes any difference?

    For further tests, is there a way to disable WP Smush CDN only on that site? I bet the image will show up afterward (after I re-empty the cache).

    I'm afraid, at the moment the only option to enable or disable Smush CDN specific to the subsite is to disable the network settings in Smush side, so that the Smush settings as a whole could be configured individually per each subsite.

    Other than that at the moment, I'm afraid there isn't an option to disable CDN out of the box for a specific subsite. Please check whether the mentioned option would help regarding this or not for your use case.

    The only other issue we've found is with Envira (see attached file). Reference: https://www.erictruchonphoto.com/

    I tested in my system, and I could replicate this issue in my side. Seems more like a compatibility issue with the gallery plugin, and might be related to how the plugin outputs the content. Will report this to our developers, and will check further about what could be done further regarding this with an update asap.

    Please let us know how the anomalies noticed with ericperreault.ca page goes. Have a nice day ahead.

    Regards,
    Nithin

  • Vince
    • Flash Drive

    Hello Nithin,
    You are correct, there is a cache when you are not logged in (WP Rocket). To make the tests easier, I disabled Smush CDN and emptied the cache. We can now see the image properly from the front-end. Here: https://www.ericperreault.ca/

    My first guess would be that Smush CDN doesn't manage URLs in other HTML attributes (such as data-lazy-src in this case) when there is lazyloading involved.
    <img alt="Image" src="https://www.ericperreault.ca/wp-content/uploads/sites/86/2018/11/slogan.jpg" data-lazy-src="https://www.ericperreault.ca/wp-content/uploads/sites/86/2018/11/slogan.jpg" class="lazyloaded" data-was-processed="true" width="1618" height="334">

    For the other points, that's perfectly understandable and the follow-up itself is all we needed. Thank you very much!

  • Nithin
    • Support Wizard

    Hi Vince,

    My first guess would be that Smush CDN doesn't manage URLs in other HTML attributes (such as data-lazy-src in this case) when there is lazyloading involved.

    The image is loading via img tag, so it should have moved to Smush CDN out of the box. However, it's tough to say what exactly could be causing this without giving a closer look at the subsite dashboard side.

    Since I'm getting redirected to the login screen due to the mapped domain support access isn't help much in accessing the dashboard.

    Could you please share your websites super admin login, so that I could manually access the subsite dashboard, and check further regarding what could have been missing regarding these?

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Vince,

    Hope you are doing good today. :slight_smile:

    Thanks for sharing the login, I gave a closer look and could notice the issue. It seems to be a known issue and we are working on a use case on what could be done in such case. It shouldn't be a common issue.

    The WebP settings enabled was causing this, and the easiest workaround would be to resave the reported image via Photoshop or anyother image editors, and re-uploading it again should work fine.

    I have already uploaded the image(slogan-one.jpg) in the Media > Library of the subsite dashboard. You can either use that or redo in your side and check whether you still have any anomalies regarding this.

    Hope that helps. Please do let us know if you have any further query. Have a nice day ahead.

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.