[SMUSH] smush CDN slows down image load

I'm using CDN but things like the logo is taking 4.49s to load which seems excessive.

  • wp.network
    • The Bug Hunter

    Mohmmad Sharab Adam

    I just glanced at this, can add this data to help confirm at least occasionally occurring issue:
    https://gtmetrix.com/reports/thepanicroom.net/S6jl5obE

    ...so, yeah, over .5s initial connect and then up to 4+s wait on receive... is, well, not great -- seems to me like its probably mostly on the SmushCDN side of things, obvs. idk what could be at play though...

    Adam I will say that if you have good hosting then any budget CDN will likely be slower than direct to server if the overall load on site is relatively low -- CDN is most useful when the load is high, or variable to high, so that there is a better average acceptable performance. So, an obvious thing to do is get hosting that provides the baseline performance that you want, and then use CDN to help maintain acceptable perf when load is high/variable (and obvs. also if you have specific need to get into edge networks, or other features eg. DNS/WAF/etc) -- all imho, of course. Hope this is helpful :slight_smile:

    Cheers, Max

    • Adam
      • Flash Drive

      Hi there.

      I don't really agree with this, and rather than fixing the issue, it's passed back to us. The slogan on the CDN option says 'Take load off your server by serving your images from our blazing-fast CDN.' - It's not very blazing when it's taking over 4 seconds to load a small logo. I'd probably change that to crash and burn... you've also said that it'll 'take the load off your server' but you're suggesting our server could be faster...

      Using a CDN should be quicker. We have a good server but with 200 + websites on it, we need to ease the burden by using a CDN.

      4 seconds for a small logo/image isn't acceptable at any server/CDN so please could you escalate further and resolve?

      • wp.network
        • The Bug Hunter

        4 seconds for a small logo/image isn't acceptable at any server/CDN so please could you escalate further and resolve?

        Adam I am just a community member who saw your thread... was trying to be helpful be providing data to verify what you had been describing -- then I also included some opinion, no intent to say that your server isn't awesome, just tried to write without assuming you had deep tech exp., etc.

        So, yeah, 4 seconds is obvs. a hard fail & yet also seems obvs. this is an edge case (its intermittent, etc.) -- fwiw, I'll stand by my opinions; they were offered in good faith, ymmv :slight_smile:

        Cheers, Max

        • Adam
          • Flash Drive

          Sorry Max, I thought it was a reply from their support... As they haven't replied in a while hence the rant. So apologies for that!

          Yeah I think I might have to rely on our server for the time being.

          Thanks Max, rant over :slight_smile:

  • Mohammad Sharab
    • Staff

    Hello Adam ,

    hope you're doing good today and please excuse my late reply here. As that I was trying to see if devs have any idea what's going on based on the info I had. As we couldn’t replicate your issue.

    Please note to avoid future confusion that the Staff responses have a blue background.

    That said, to further investigate the issue as all speed test results showed us the logo loads in ~ 695.1ms, I disabled you Smush CDN then tested the logo loading speed. The results show that the logo loads in 202.9ms which is faster than the one served with Smush CDN.

    Then I had to test it again after enabling CDN but when I tried to enable Smush CDN again it kept loading forever. The console shows 500 error “Failed to load resource: the server responded with a status of 500 ()”. and this could be due to a plugin conflict but to get a better insight we would like you to enable debugging.

    To do so, please access your server via (S)FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false); and replace it with the following (if the above line doesn’t exist, simply insert the following snippet just above the /* That's all, stop editing! Happy blogging. */)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to activate Smush CDN.

    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If the size of the text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Reference: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Best Regards,
    Mohammad Sharab

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.