Smushing multiple images doesn't work

Recently upgraded to WP Smush Pro to be able to smush all images at once. However when I try to smush multiple images, no matter how long I wait it just does one image at a time...It would be faster to do it one by one at this point. Why could that be?

I look forward to hearing from you! :slight_smile:

  • Nastia

    Hello @Anna, I hope you are doing well today!

    Make sure that you have deleted the Lite version of the plugin.

    This also may happens because of the conflict with a plugin. Would you please run a quick check for a conflict with a plugin/theme?

    Deactivate all other plugins and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Did all your images were already smashed before? In case they have already been comressed, the WP Smush Pro plugin will not compress the images for the second time.

    Please advise,

    Cheers,
    Nastia

  • Anna

    Hi Nastia!

    I deactivated all plugins and the problem is still there :slight_frown:
    I also deleted the lite version of the WP smash plugin (it was deactivated before) so now all the files that were previously smushed aren't anymore and I have to start from scratch...

    I'm not very "techy". If I change the theme to a default version I'm afraid I'll lose all my settings.. It happened before...

    I should probably also add that the normal WP smush version used to work better, and then a few days ago it started acting like this, even though I didn't install any new plugins.
    This is why I upgraded to PRO version as I thought it would help.

    I don't feel comfortable changing the themes myself because of what happened to me the last time :slight_smile: I ended up having to restore my site.

    I would appreciate the help. Thank you.

  • Nastia

    Hello @Anna, I hope you are well today!

    Would you be able to grant us support access so we can take a closer look?

    You can grant support access via admin dashboard - WPMU DEV > Support
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    If I change the theme to a default version I'm afraid I'll lose all my settings.. It happened before...

    We always advise before making any changes, to make a backup of the website. If something goes wrong, you can always restore the site to previous state.
    In case you might want to take a look at Backup plugin:
    https://premium.wpmudev.org/project/snapshot/

    Once you grant access, please post here!

    Cheers,
    Nastia

  • Nastia

    Hello @Anna, I hope this message find you well!

    Thank you for granting support access!

    I notice that the webpage going a little bit slower while the bulk smushing is activated. After several minutes of bulk smushing I've got the following server error:

    Service Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    To fix this, we have to increase the PHP memory. Please, connect to your server and locate the wp-config.php file. This file is located in the root of your WordPress file directory and contains your website's base configuration details, such as database connection information.

    Add the following to the very bottom, but just before the “happy blogging” line:

    /** Memory Limit */
    define('WP_MEMORY_LIMIT', '120M');
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );

    More information t increasing memory limit:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If you need assistance with this, please let us know!

    Awaiting for your response.

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.