Snap-Shot not Snapshotting

Hi, I have snapshot installed and it isnt creating the snapshots. I have deleted them and reloaded and cannot get them to snapshot. Can you please help

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi there,

    I hope you are doing great today and thank you for contacting us. I am sorry that you are facing issue with Snapshot. Are you trying to take a manual backup or scheduled backups?

    Please allow support access so we can have a closer look at this on your end.

    To enable support access you can follow this guide here:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    For the time being, please do the following for me which is a major step towards resolving the issue:

    1. Enable debug logging. You can do this by adding the following lines to your ‘wp-config.php’ file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. Add the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.

    a. Create or edit php.ini in your website’s root and add the following line:

    max_execution_time 300

    b. In .htaccess add the following line:

    php_value max_execution_time 300

    c. in cPanel you can go to “Software > MultiPHP INI Editor”, choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again, please try to set it to “Daily” so that we can have results soon for the Scheduled Backups, you can change later. If you are facing problem with manual backup then you can immediately try a backup and update us.

    Let me know how it goes.

    Best regards,

    Nazmul

  • Steve
    • The Incredible Code Injector

    Hi Nazmul H.

    Thank you for your reply. There is a lot to do here. I have tried to do back up manually (as in run now) and scheduled and neither were working.

    I have made all the changes outlined above and now it seems to be working. I will keep an eye on it over the next few days to make sure it continues and if so close the ticket. Thanks for your help. Steve

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi there,

    Thanks for updating. Glad that it’s working now. I believe this was something to do with the memory and execution time. Hopefully you won’t face any issue again. If you face this again, we are always here to assist you.

    Have a nice day. Cheers!

    Nazmul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.