Snap Shot Plugin Stops at Files

I am trying to take a Snap Shop Backup of my customers website and in keeps getting stuck on the Files: section - Then a big image of a 404 page from my website shows up in the same window.

  • Tyler Postle

    Hey Mike,

    Hope your Friday is going well so far!

    It looks like this is due to a server timeout as your max execution time is only 60 seconds.

    Try adding this to your .htaccess file:

    <IfModule mod_php5.c>
    php_value max_execution_time 300
    </IfModule>

    After you do that check the system info within our WPMU DEV Dashboard to see if the execution time actually increased or not. If not then ask your host if they can increase it for you. It looks like it's gets really close to finishing so even just bumping it to 90 might do the trick.

    System Info:

    Max execution time:

    Let me know how it goes!

    Cheers,
    Tyler

  • Mike

    Ok,
    Tried everything you asked me to do - I am on a shared hosting server with Green Geeks and they only allow 90 for the max_execution_time. I changed it to 90 and still having a problem - I guess this will not work for me then because I have like 30 websites that I wanted to do this for and don't have any problems with other backup plugins. I wanted to use your system but I don't want to pay for your service and still have to use other plugins when yours don't work. I have been spending way too much time trying to get this one to work.
    Thanks for your time!
    Mike

  • Tyler Postle

    Hey Mike,

    I'd recommend using our managed backup feature instead. It's a new feature we just added that integrates with our on-site Hub.

    It uses a completely different backup process versus the standard Snapshot backups so it will do the backup in chunks instead of all at once like a Snapshot is.

    The reason we didn't completely replace the regular Snapshots with the Managed service is because a lot of members still use regular Snapshots and they integrate with services like Drop Box and we don't currently support third party services for the Managed Backups.

    I can see that you already turned Managed Backups on and it's currently running. So we'll see if it finishes. If for any reason it doesn't then the nice thing about Managed Backups is that we can adjust the chunk size so if it's an execution time issue we can make each chunk smaller so it will take less time to execute them.

    Let me know if you would be interested in continuing with that :slight_smile: you can also save the managed backups locally too in addition to on our secure servers.

    Cheers,
    Tyler

  • Tyler Postle

    Hey Mike,

    It looks like you are hitting either a timeout or memory issue.

    Can you try adding this to your wp-config.php:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);

    above this line:

    /* That's all, stop editing! Happy blogging. */

    That will make the chunk size for your files smaller and hopefully more manageable for your hosting.

    After adding that, reactivate the Managed Backups, you can also manually initiate the backup process from the top of that page but keep in mind when it is done manually then you will need to keep that tab open while it performs the backup.

    If it's still not working then could you send in your cPanel info? That will allow us to investigate the issue further :slight_smile:

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -cPanel login url
    -cPanel username
    -cPanel password
    -WordPress admin username
    -WordPress admin password
    -login url
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Talk to you soon!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.