Snapshot

I have installed snapshot & linked it with dropbox - however I cannot seem to change the backup interval? I did an immediate back-up from first use locally - before changing the options to dropbox, I don;t know if this has conflicted anything?
I have made a backup to dropbox but this again was using the immediate set up. Would like to have the option to get this weekly - Any help would be appreciated -
P.s - I'm a newbie to wordpress :disappointed:

  • Paul
    • The Green Incsub

    @jayblighty, not sure I understand you comment "however I cannot seem to change the backup interval?" Are you stating you don't know how or that you have tried and it will not correctly update the value?

    You should be able to switch from manual to scheduled and local to Dropbox without issue. But try creating a new snapshot item with Dropbox and your weekly scheduled interval. See if that gives a better solution. I've had one other report of the interval not updating. But that was Snapshot 2.0.3.x version.

  • Justin
    • Flash Drive

    OK, I need to be clearer :slight_smile:
    I just wish to have the option of using the drop-down menu & being able to select scheduled options - but, for some reason the only option available to me for selection is 'Immediate'?
    I have no option to select scheduled? They are viewing in the menu but they remain un-selectable?

    Is this because I ran my first copy to my local server under immediate? I don't know.
    But I am now set up to Dropbox & my accounts are synced & do work with the immediate choice - but I have not the option to schedule to Dropbox?

    Thanks :slight_smile:

  • Paul
    • The Green Incsub

    @jayblighty, Ah. No, you are not seeing the schedule options because Snapshot thinks you have WPCron disabled.

    So try this. Go to Snapshot > Settings There is a big section 'Server Info'. If should have a line there about WP_CRON being disabled in red.

    If you see it then for some reason you have a setting in your wp-config.php or some other plugin has disabled the WP_CRON completely. Snapshot cannot perform scheduled backups because WP_CRON is not functional.

    Report back.

  • Paul
    • The Green Incsub

    @jayblighty, What other plugins are you running? Running anything that might effect WPCron? The reason I ask is as part of the Snapshot setup it registers a bunch of intervals with WordPress. These intervals are what is shown on the drop down.

    There is a filter used 'cron_schedules' which is where Snapshot adds theses new intervals.

    add_filter( 'cron_schedules', 'snapshot_utility_add_cron_schedules' );

    If could be that you are running another plugin which is also using this filter.

  • Justin
    • Flash Drive

    Hi Paul,
    My list of Plugins are:

    Add This ( social bookmarking )
    BP Group e-mail
    BP Activity +
    BP Group Calender
    Contact Form 7
    E-mail Login
    E-mail Newsletter
    Gravity Forms
    JW Player plugin
    Q&A
    Really simple captcha
    Ultimate TinyMCE
    WP polls
    WP survey & Quiz Tool
    + 3 plugins from onesportevent

    That's the lot :slight_smile:

  • Paul
    • The Green Incsub

    @jayblighty, ok. Guess my assumption was the schedule intervals were not showing at all. Please confirm you see some or all of these from my screenshot so that I'm correctly understanding your issue.

    As for not being able to select them what browser are you using? Have you tried other browsers?

  • Paul
    • The Green Incsub

    Also please be specific from your previous message you wrote "Only able to select immediate" There are two ways to interpret that comment.

    1. The options are in the dropdown but you cannot click on them to select.
    2. You can click on these interval options but when you save the form it does not update the interval.

    Hopefully we are getting close.

  • Justin
    • Flash Drive

    @Paul

    OMG.....Please forgive me ....Yep you hit the nail on the head Paul,

    I just checked out IE & it worked fine ....then

    I cleared my Google Chrome cache & guess what....? yep it worked fine :disappointed:

    Somebody flog this man,,,lol .... I mean seriously......

    I'm just glad it was simple to be honest, & many thanks for hauling along with
    me on this dusty windy road to nowhere -

    Thanks for your troubles Paul, here have a virtual beer on me.... :slight_smile:

    Cheers,
    Justin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.