Snapshot 524 error Dropox

Trying to create a Snapshot to Dropbox destination, and getting the following error:

Did try increasing the memory limit still the same issue.

  • Nithin

    Hello Chris Anderson,

    Hope you are doing good today. :slight_smile:

    I ran a Snapshot to the local destination, and I was able to replicate the same error. in your system. Seems like the issue is in general with Snapshot, and not specific with snapshot related to Dropbox.

    Since we lost connection to the chat, I wasn't able to check the the debug log which we got enabled during live chat. So wasn't able to troubleshoot further. Please follow up with Jorges email regarding credentials of your site.

    However, on checking the existing setup during our chat conversation, I could notice via the phpinfo.php file that you have created under:
    yourWebsiteURL.com/phpinfo.php

    That the memory limit wasn't really increased in the server side, the server is still detecting memory limit as 512M, instead of 1024M. The Memory limit increased via the wp-config.php might , not help in this case.

    As mentioned, 524 error could also related to having a low server resource. So, would recommend you to please create a php.ini file in the Root Directory, and add the following rules to it, and see whether memory limit gets increased, or not.

    upload_max_filesize = 256M
    post_max_size = 512M
    memory_limit = 1024M

    And see whether this increases the value when checked under phpinfo.php page. Root Directory is where wp-config.php, .htaccess file resides.

    If you still don't see any increase in memory limit via above link, would recommend you get in touch with your hosting provider, and ask them to increase the memory limit based on the above given values.

    Once done, please re-run a new snapshot, and if you still get the same result, please share the debug.log file which got generated in your site in your next reply, so that we could see whether there is anything specific related to this.

    You can find the debug.log file, located under /wp-content folder. You'll have to use FTP to download the file.

    However, since the 524 error is specifically related to Cloudflare, would also recommend checking with Cloudflares support to see whether it's something they could correct in their side too, like adding an exception in the /wp-admin if possible , or not.

    Please let us know how that goes. Have a nice weekend ahead. :slight_smile:

    Best Regards,
    Nithin

  • Chris Anderson

    Cloudflare reply:

    Hi Chris,
    Thank you for contacting Cloudflare Support. I am sorry to hear that you are experiencing some difficulties here. Unfortunately the Cloudflare HTTP timeout is a network wide setting that can't be altered, if you need to have scripts that run for longer than around 1m40 without returning any data we will present Error 524: A timeout occurred. There are a couple of options we'd suggest to work around this:
    1. Run the scripts via a grey-clouded subdomain
    2. Change the script so that it kicks off a long-running background process, and quickly returns a status which the browser can poll until the background process has completed, at which point the full response can be returned. This is the way most people do this type of activity these days - as keeping HTTP connections open for a long time is unreliable and can be very taxing also.
    3. If you really need this feature, we can increase the value for our Enterprise customers as part of a custom set up

    We've established through live chat today that these are not possible. I need you to investigate if there are any other options to get these three variables to work together. For the mean time, I'll be working on an automated work around in cloudflare.