Snapshot an error occurred while processing plugins directive

Hello,

I just installed snapshot and ran a backup which got aborted in the last stage due to red error:
"an error occurred while processing this directive".

How can i solve this issue and get a complete and safe backup of snapshot.

Many thanks.
Best wishes,

David

  • Panos

    Hello Dr. David ,

    Hope you are having a nice weekend :slight_smile:

    This error message you are referring to is quite generic. Could you please enable debugging by inserting the following snipped to your wp-config.php:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    This will create a new file "debug.log" in your wp-content folder which will provide further information about what is causing this error. So, after pasting the above snipped in your wp-config.php file, download the debug.log file to your desktop, compress it (zip it) and attach it here so we can have a look at it.

    Before compressing the debug.log file, make sure that you mask any reference to any sensitive information about your site (like replace your actual site url with "http://my-site.com") as this is a public forum.

    Kind regards,
    Panos

  • Dr. David

    Dear Panos,

    I have sent information via 'other question' and here the debug log Please feel free to check all necessary reason why backup doesnt work, since it is a previous restored version via my server (not via plugin) i do not have the redirect members plugin on it, last days were given to re-create content i have lost due to the very early restore point, so when snapshot will be working i will not lose so much information due to crashes of plugins and themes with each other...

    Lots of thanks for the assistance my friend.
    Best wishes,
    David

    PS
    For some reason the wpmu interface denied my debuglog.zip upload, it is on my server, which access is given via 'other'

  • Panos

    Hello @Dr.Dr. David ,

    It seems that Snapshot is not the one that causes this error, one of the plugins is causing it when trying to keep a files backup with snapshot.

    Let me explain what I have tried:

    1. Set Snapshot to take a database backup only, succeeds

    2. Set Snapshot to keep a backup of all files except plugin (themes, media etc, but not plugins), succeeds

    3. Set Snapshot to keep a backup of the plugins only, causes error.

    I had renamed the plugins folder to plugins_wpmu, and created a new plugins folder where I installed the WPMUDEV dashboeard plugin, Snapshot, Akismet, Membership and ajax-search-pro, Google analytics, and generally all WPMUDEV plugins you had installed plus one two of the others. Then I made a new plugins backup with Snapshot with no errors.

    Currently I have restored the previous plugins folder to the one you had, and I have renamed the plugins folder I managed to keep succesfull backups to plugins_wpmudev. I would recommend to rename them again back and install one by one the plugin you had and each time keep a backuo of plugins folder only (which should be fast). That way you will find which plugin causes this.

    Kind regards,
    Panos

  • Dr. David

    Good Morning Panos!!!

    How are you today? :slight_smile:
    After long night of testing i found the plugin causing the issue, it's thrive builder... i have to find out the reason why it is doing so, what kind of conflict this plugin creates to snapshot making this error.

    I am testing now having only Thrive in the plugins, and see if there is an error, or the error comes from being present with other plugins.
    Got to run to my day job now...many thanks.

    Best wishes,
    David

  • Dr. David

    Dear Panos,

    ***edit: I just try to have only Snapshot and Thrive, and it backup succesfuly, so it seems its the presence of Thrive with other plugin at the same time that causing this error, if such thing could even exist...
    I will ask them but most probably they will (like almost all plugin owners) say that they are not responsible to be compatible with all other plugins, and that they work well with other backup plugins. Is there something more specific as to why Snapshot Pro cannot backup this folder, why is it impossible to copy it? Is there some unreadable code somewhere who prevents Snapshot from doing it? In Snapshot software, to what kind of data corruption it shows that ref message ""an error occurred while processing this directive"."
    If i could be more specific as it is a heavy plugin, they would probably be more willing to look into it.
    Also, what do you recommend doing if still it is impossible to back up, should i copy all plugins manually, as i cannot choose to exclude it while backing up the 'plugins'

    Many thanks for the help and have a great day!
    David

  • Panos

    Hello Dr. David ,

    I wonder if this is caused due to memory limitations.

    Could you please try following? First visit your Snapshot settings (admin menu > Snapshot > Settings) and at the Memory Limit field insert a higher value (like 2G). If it doesn't make any difference try increasing memory limit by iserting/changing the following in your wp-config.php:

    define( 'WP_MEMORY_LIMIT', '2000M' );
    define( 'WP_MAX_MEMORY_LIMIT', '2000M' );

    or by following this article: https://premium.wpmudev.org/blog/increase-memory-limit/

    After changing it you should better visit again Snapshot settings page to check if the value set previously hasn't been changed at the Memory Limit field.

    Please let us know how it goes!

    Cheers,
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.