Snapshot and DEFENDER problems!!

I have multiple WP sites added to WPMU and have attempted to initiate SNAPSHOT backups to Dropbox with several of the sites with NO SUCCESS on any of them. Again, this is one of the primary reason I am paying for your service.

Today, I got farther than normal with website backup on http://www.psychicmediumchuckieg.com and it got "stuck" at Files: Plugins ...it stops at 72% and stays there and does not complete the backup. I have tried this twice this morning on this site and waiting nearly 45 minutes for it to finish. I have spent hours upon hours on other website without any success. My first thought was the Dropbox was not accepting the backup file although WPMU is authorized to do so.

ALSO, even though I had defender installed I believe the site has experienced some malicious code being embedded because when I attempt to access the site through the host's control panel I am taken to a 404 page AND there is a deleteme file created in the wpcontent file. After talking to godaddy they suggested that I should remove the DEFENDER plugin!!! What is unusual is that I can still access the dashboard direct via wp-admin login.

  • Rupok

    Hi Kathy,

    I'm so sorry to hear the inconvenience you are having. Thanks for granting Support Access. I logged in and tried to create a backup and I could regenerate the issue (getting stuck at "plugins" folder) on your site.

    As the backup process is getting stuck on your plugins folder every time, so I think, some/any of your plugin is causing this. To find out which plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I believe, you will find the problematic plugin after this test. And when you can identify that one, deactivating that plugin will allow you to create regular local snapshots as long as dropbox snapshots. Please let us know how it goes.

    Regarding your Defender query, this is really very weird and should not happen. Defender checks all your files with fresh WordPress core files and if any file is not similar to the fresh core file, it should give you warning. So chances are very low that malicious code is inserted in your site and Defender is not giving you any warning about that.

    Now, as you said you are having this problem in GoDaddy, can you please tell us which GoDaddy hosting plan are you using? If possible, can you please try to regenerate the same issue in another server? As far as I know (Please NOTE, I'm not sure about this), GoDaddy adds some custom files in the root directory of your WordPress instances which are not native WordPress files. But when you protect your site with Defender, it stops executing PHP files from secured locations and take some other steps to make your site more secure. That might interfere with GoDaddy custom functionality like direct login to your Dashboard (again I'm saying, I'm not sure but chances are there) or other features.

    So can you please tell us details about your GoDaddy hosting plan so we can try to regenerate the same issue and if we find any issue, we can work on that to fix this?

    Please send us as much details as you can. I'll forward all these to our developer as soon as you send us.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Kathy,

    Continuing with backup concern.
    I have disabled all the plugins except for the WPMU dashboard and of course Snapshot plugin. When attempting to do the backup it is still getting stuck at "plugins" folder.

    Thank you for sharing your observation, to troubleshoot this issue further, could you please enable debug mode, so that we could have a better idea about this. To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please try to perform a new snapshot. If the snapshot fails, the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kathy

    Backup still not working and again stops at 72%

    I have added the code and changed to the define('WP_DEBUG', true);

    AND added
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please find error log attached.

    NOW within WP Dashboard an error message is appearing:

    Notice: Constant WP_DEBUG_LOG already defined in /home/willowmarketing/public_html/psychicmediumchuckieg.com/wp-config.php on line 106

    Notice: Constant WP_DEBUG_DISPLAY already defined in /home/willowmarketing/public_html/psychicmediumchuckieg.com/wp-config.php on line 107

    Please advise.

    Kathy Kohler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.