Snapshot and sub folders on Dropbox

Hello there, I have installed Snapshot on a further website in order to setup a Daily dB and a Weekly File and dB backup.

I have authorised the Destination on Dropbox https://www.dropbox.com/home/Apps/WPMU DEV Snapshot/TKA/ and it seems to run the backup process ok and I can download the file. But I can't see it in the Dropbox folder.

I'm a little confused as to where the files are going.

The destination directory is correct as far as I can see, I'm just really confused as to where the file actually is.

Other backups that I have working put the files in the next level up in the directory, but i wanted to start using a sub folder to manage the files more effectively.

Any help much appreciated.

Maria

  • Predrag Dubajic
    • Support

    Hey @Maria,

    Hope you're doing well today :slight_smile:

    What do you have in your destination field?
    When you change destination folder try enabling Force Re-Authorize with Dropbox option before saving changes and see if that helps.

    Also note that it takes few minutes until file is uploaded to dropbox after snapshot has been created :slight_smile:

    Best regards,
    Predrag

  • Maria
    • WPMU DEV Initiate

    Hi Predrag,

    Thanks for the response.

    My destination field is set to https://www.dropbox.com/home/Apps/WPMU DEV Snapshot/TKA/ - and i have done as you suggested and Force Reauthorised.

    My directory is set to /Apps/WPMU DEV Snapshot/TKA/

    I'll keep an eye on it but nothing seems to have appeared in my Dropbox folder yet. I'm wondering is there is something wrong here with my setup ?

    Many thanks,

    Maria

  • Maria
    • WPMU DEV Initiate

    Hi there, Thanks very much Predrag ... I have enabled access. Yes, its working fine on another multisite install that I have, adding the files to the top level of the directory. Its just this one with the the sub folder setup ? Thanks for taking a look for me, I did check this morning and see if there were any backups on Dropbox and still none as yet.

    All the best,

    Maria

  • Predrag Dubajic
    • Support

    Hi @Maria,

    Sorry for delay, I'm unable to log in to your site, I keep getting Sorry, this is an invalid access token. You must ask the user to grant access., can you please revoke access and then grant it again this usually fixes this.
    I would like to connect to my dropbox account on your site and test this.

    Best regards,
    Predrag

  • Maria
    • WPMU DEV Initiate

    Hello there, sorry for the gap in response ... I hope you had a good Easter too :slight_smile:

    I have just re-activated the access to this account ... hopefully that will do it for you, if not I can send the WP login.

    Many thanks,

    Maria

  • Predrag Dubajic
    • Support

    Hey @Maria,

    Sorry for the delay, re-activating access worked and I was able to log in to your site.

    I have added my Dropbox as destination and created two snapshots and as you can see from the screenshot below sending files to Dropbox are stuck as pending.

    Do you have any security plugins that can be causing this?
    Also, can you check if your server is blocking any outgoing connections?
    Did you try disabling other plugins and leave only Snapshot running so we can see if there are any conflicts with them?

    Looking forward to your response.

    Best regards,
    Predrag

  • Maria
    • WPMU DEV Initiate

    Hi Predrag,

    Thanks so much for this. I don't have any security plugins running, but this site is on a different server to the host I usually use ( my client wanted to stay with their old host ).

    I am wondering if this is the problem as they have captcha at login and a few other things. I'll check with them on outgoing connections.

    Will also look at plugins on this live site just in case.

    Thank you very much .. Maria

  • Maria
    • WPMU DEV Initiate

    Hi Prendrag,

    The response from the site host is as follows.

    We wouldn’t be blocking any connections that the site is making. Would you happen to know if your plugin works through a loop back connection? Loopback connections are blocked.

    I asked if they could unblock the loopback connection and this is the response.

    ---- I think you mis understand – the plugin is using the loopback – is there an alternative configuration you can use with the plugin – I am investigating alternate crons for you. ----

    1. I am not sure what a cron is, and if this will help 'unblock things' ?
    2. Is there an alternative non-loopback configuration I can use for the plugin as requested in this instance ?

    Sorry, this is a bit vague, I am having a little trouble understanding but maybe this makes more sense to you guys.

    Thank you, Maria

  • Predrag Dubajic
    • Support

    Hi Maria,

    Thanks for getting back with this info, I think we would need some help from dev guys regarding this but let's try one more thing first.

    Instead of creating manual snapshot try setting it up as scheduled snapshot and see if it will save it correctly that way.

    Let me know how it goes.

    Best regards,
    Predrag

  • Maria
    • WPMU DEV Initiate

    Ok, I'll try this ... and also setup a duplicate test site where i try with all other plugins turned off, I am reluctant to do this on the live site as it has been handed over. Will let you know how it goes. Thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.