Snapshot backup failing

Trying to migrate website using snapshot. Backup up site (database only) keeps running into an error: An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.

  • Nithin
    • Support Wizard

    Hi Jamie Goldman,

    Hope you are doing good today. :slight_smile:

    Could you please try adding the following rules inside the wp-config.php file, and then check whether it brings any improvements regarding backups.

    define('SNAPSHOT_MB_BREADTH_FIRST', true);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    Please make sure to place the above code, just before the line /* That’s all, stop editing! Happy blogging. */

    Once done, please run a new backup and see how that goes. If you still notice issues even after that, then would recommend you to enable debug mode, so that we could troubleshoot this further.

    To debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to run a new backup. If the backup fails, the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Kris
    • Support

    Hi Jamie Goldman

    Above error is related to memory_limit on server side.

    Are you able to increase this value in cPanel or just add this define in wp-config.php file:

    define('WP_MEMORY_LIMIT', '512M');

    This define should be placed above the “/* That’s all, stop editing! Happy blogging. */”

    and then try again.

    Hope this help :slight_smile:

    Kind Regards,

    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.