snapshot backup isn't work

Hai,

I'l try to get managed backups for this website, but for this website it isn't work. Can you check if I have al settings done right?

greeetz, Marcel

  • Predrag Dubajic

    Hey Marcel,

    Hope you had a nice weekend :slight_smile:

    Is this happening only on this site or your having issues on others as well?

    If it's working on your other sites can you tell us if they are running on same server or on different ones?

    Also, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Dimitris

    Hello Marcel ,

    hope you're doing good and don't mind chiming in here! :slight_smile:

    this site is running on another server. from Siteground.

    Could you please inform us about the exact package you're using? Is this a shared account or a VPS? Please advise!

    Let's follow some basic debugging steps here please. We'll try to increase the allocated to PHP memory, use smaller chunks of files and DB tables during snapshot backup process and enable WP_DEBUG to log any related error messages.

    Before doing so, please ensure that no manual backup is running and temporarily disable automated backups. You can do so if you remove the Snapshot key in Snapshot -> Managed Backups and update settings.

    Then please access your server through FTP edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the followings (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
    define('WP_MEMORY_LIMIT', '512M');
    // Snapshot definitions
    // *Important:* the chunk sizes have to be fixed for each backup. So, if you'll be making use of this define, please make sure there's no manual backup running and temporarily disable automated backups.
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    I've also set the debug levels in Snapshot -> Managed Backups to "info" so we could grab all related information.

    Then go ahead and re-enter your Snapshot key, activate scheduled backups in daily basis and wait until it triggers. Spare some time until the procedure ends (some hours should be enough).
    By doing so, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply (if file is larger than 5MB, please use a service like Dropbox and post the shareable link instead).

    Warm regards,
    Dimitris

  • Dimitris

    Hello Marcel,

    hope you're doing good today! :slight_smile:

    It's Growbig hosting, https://www.siteground.com/wordpress-hosting.htm

    I'm using the GoGeek package, so it may be a resource issue in the end.
    Also please mind that we both get an automated backup of the last 30 days, made internally by SG.

    In the attachment the debug.txt.

    It seems that the text file never got attached.
    Please keep in mind that .log files, or files larger than 5MB can't be uploaded.
    If you find it easier to use a service like Dropbox, or Google Drive, please do so and post the shareable link instead.

    Unfortunately the Managed Backup error didn't revealed much, well, at least more than this:

    [snapshot][2017-04-11 01:02:57][Info] Created the backup and added the queues
    [Cron][2017-04-11 01:02:57][Info] Next process kickstart action scheduled for Tue, 11 Apr 2017 01:07:57 +0200
    [Cron][2017-04-11 01:34:00][Warning] Immediate hook misfired, kickstart backup processing

    and afterwards the cron job seems to fail.
    Please keep in mind that in order for cron jobs to get triggered, there should be some actual traffic in your website. I noticed in Google Analytics widget in WP admin Dashboard that this website just started to have some visitors, is that right?
    If that's the case, and debug information doesn't reveal anything else like a server resource limit, you may try to deactivate-reactivate the scheduled backups and keep visiting homepage. :wink:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.