Snapshot Backup not working

The snapshot on my website is not working. I tried increasing the max_execution_time and also chunked up the Snapshots but still no avail.

Please assist

  • Predrag Dubajic

    Hi Manelle,

    Hope you're doing well.

    I had a look at your site and while in your admin I noticed some strange behavior.
    While the backup does fail and shows 404 error I had a similar thing happening with other sections of your site.
    Your other pages are going to 404 page on random times as well, here's an example of me trying to access your plugins page:

    I also had this happening on other pages of your backend, Settings, Themes, etc.

    The thing is that the issue comes and goes, sometimes I can open those pages and sometimes I can't, and I believe this is affecting backup process as well, because when I created a small backup that finished quickly it worked fine, probably because all the links were correct.
    But when I started a larger backup it failed again and went to 404 page.

    So first thing that needs to be done is make sure that the links on your page are working correctly, I would suggest that you start by backing up your .htaccess file and then use the default WP rules in there to see if that helps and if some of the other rules were causing this.

    If that doesn't help try performing basic troubleshooting by disabling your plugins and switching to default WP theme to see if site works fine after that.
    If it does then activate them back one by one until you find which one is causing the issue.

    Let us know how it goes.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Manelle

    Are all these sites on the same server or on different servers?

    Let me know please but let's for now focus on the one in question anyway and then, depending on the outcome, we'll either "copy" solution to other sites or investigate them separately.

    I'll be glad to assist you further but in this case I'll need a full, direct access to the site and server. Would you please provide me with access credentials?

    Note: Don't leave your login details in this ticket.
    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Manelle,

    Thanks for sending those in.
    I had a look at your .htaccess file and everything looks fine there so it seems that there's something else causing this.

    I did try running another backup on your site and this time I was able to create backups without any issues, you can see in Snapshots panel that there are now backups of Files, Database and Full backup as well.

    I also wasn't able to see any of the 404 errors when accessing your admin pages so it definitely looks like these issues were related.

    So it should be working fine now, but if the 404 errors start happening again the backups will probably stop working again as well.
    And if that does happen, ask your hosting provider to check the server logs and they should be able to find more info about those redirects and what's causing them.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Manelle,

    However, when I tried to run a full backup it didn't work for me.

    Just to be sure that we're talking about the same thing here, did you try to do local Snapshot will all the files and DB included, or you're referring to Managed Backups?

    Also, I still can't get it to work on my talesfantastic.com site or starstructuretoys.com.

    Are you getting the same 404 errors as on initial site where we were checking this or you're getting some other errors there?
    Did you contact your hosting provider to check server logs and see if there's additional info there on what's going on?

    Best regards,
    Predrag

  • Manelle

    So I tried to do the Managed back up on Manelleoliphant.com and a snapshot on the other two sites.
    To me it looks like the same 404 errors as before on all three sites.

    I just looked for server logs. I'm not exactly sure what I'm looking for but I don't see any error logs. I talked to the web host support and they helped me set things up differently. I don't know if it worked yet. I'll get back to you tomorrow.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.