Snapshot backup restore

I was in the process of commenting on an assessment for a student when all of a sudden the page moved backwards and now all of the students work on every course has disappeared! I am trying to restore a snapshot backup but I keep getting a page not available message and the backup won't restore the datebase!!!! Please help, we cannot afford to lose all our students work :slight_frown:

Joanne

  • Adam Czajczyk

    Hello Joanne!

    I visited your site and except one snapshot ("Snapshot13new") which is still in "Pending" state being send to the destination - they are available for restore.

    In order to be able to access the "restore" option for selected archive you need to click "Restore" (not "Edit" or a snapshot name) on snapshot list first. Then after you hover over selected archive one file an actual "restore" link will appear.

    That being said, I'm wondering about what happened to your site. As you said, suddenly the page moved backwards (which most likely means accidentally hitting backspace or similar incident) and your students' work is gone. Going back to previous page shouldn't remove any data from CoursePress except what hasn't been saved yet. Therefore, I wouldn't be surprised if you had to make some assessments again but I am surprised that some work by students is gone.

    Are you sure that it is gone indeed? Could you tell me what exactly is gone from the site so I could check it (since you already granted a support access)?

    Some other behavior of the site suggests that the site may have been restored from an older backup so could you ask you hosting provider if they did any works on the server and were restoring the site from backup? It happens rarely but it does and it's worth checking.

    Best regards,
    Adam

  • Joanne

    When I choose snapshot-1456854255-160814-001438-ea5dd2a7.zip to restore its status is pending, I had to import it from the original destionation folder as all the snapshots diappeared from the back end earlier. This is getting ridiculous, this plugin a nightmare that has cost me nothing but time and money and reputation! This needs sorting and sorting tonight before my students log in tomorrow and find all their work gone!

  • Milan

    Hello Joanne ,

    Hope you are well today and won't mind me chiming here.

    Currently, I am not seeing any Snapshot has even been made on your site. Take a look at this screenshot please.

    So would you please,

    #1) Put Snapshot you want to restore in /wp-content/uploads/snapshots folder,
    #2) Go to Snapshot > Import > Click "Scan & Import" button.
    #3) Then go to Snapshot > All Snapshot
    #4) Find Snapshot you want to restore and click restore.

    Let me know how it goes.
    Kind Regards,
    Milan

  • Joanne

    I have been doing that all night! Everytime I try to restore I get an error message when it gets to the line
    KSbodGeToptions > KSbodGeToptions

    The snapshot is in the uploads folder, its in the snapshot backend, I click restore and it uploads the first 4 tables/files then it stops and says "The page you are looking for is temporarily unavailable.
    Please try again later.
    6c3c50bccd07516bcb39191096de0569 764d287ec9b0ed3349cd919dc56c049b fd108eaf5ae67f1a0e8a48d6dc69ca87".

    I need to sleep, I have been up all night and I have work in 3 hours. Please fix this for me?

    I don't know what else to do and my students will be logging in in 3 hours!
    Joanne

  • Milan

    Hello Joanne,

    Can you try increasing segment size for Snapshot Pro ? Please go to Snapshot > Settings > Segment Size. Start with 5000.

    If it does not help, we need to enable debug mode on your site which you can do by replacing this line of wp-config.php file,

    define ( "WP_DEBUG", false );

    with these ones,

    define ( "WP_DEBUG", true );
    define ( "WP_DEBUG_LOG", true );
    define ( "WP_DEBUG_DISPLAY", false );

    after that, save the file and try to replicate issue. Process will generate "debug.log" file in /wp-content/ folder.

    Download that file, and change its extension from ".log" to ".txt", and upload it in your next post. :slight_smile:

    Best Regards,
    Milan

  • Joanne

    That didn't work an to be quite frank with you I don't have time to debug, I have students logging in today! I have created a fresh install on a new domain and managed to restore the original database with everyone's work from yesterday morning, I just need panos to fix the reports issue like he did last week then I can point the old domain to the new one. This concerns me that all of a sudden all the students work for every course disappeared and snapshot lost its snapshots then wouldn't restore!!!!!!!! This CANNOT happen again so I would appreciate some support here and attention to be paid to the many issues with Coursepress Pro!

  • Dimitris

    Greetings Joanne,

    hope you're doing good today! :slight_smile:

    I'm really sorry for the frustration here. When we come to the point that we get an error, like the one you confronted yesterday, the only way is to see the actual logs in order to get to the bottom of this.
    So, did you managed to re-set this in another server instance using the Snapshot archive or not?
    In case there's still the old server instance, would you mind re-creating these debug logs like Milan stated before and send these to us for further inspecting? We may be able to extract some piece of info from there.

    I already noticed that Panos helped you out with reports issue.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.