Snapshot backup returning 502

Getting 502 error upon backing up the site with local snapshot backup and Managed Backup.

  • Tho Bui
    • Staff

    Hello Will ,

    Apologizes for the delay, I checked and don’t see any issue from the plugin. I also have tried some ways to save the requests of the backup process but still not help. The backup is stuck when the backup size is large.
    And looks like your hosting provider hides all the log files so I can’t check for detail. I tried to clone the site to my local and the backup can create sucessfull without issue. In that case, I will forward this to our dev hope they can help you.
    And the backup file was created successfully at 26/08/2019. Do you have any change from plugins/themes (ex: add new plugin) after this time? Also, that’s good if you can contact your hosting provider to enable the log files.

    Kind Regards,
    Tho Bui

  • Leonidas
    • Developer

    Hi there Will ,

    I tried to take a further look into your reported issues, in case we find a way to make backups work on that site, but like my colleague Tho Bui mentioned, it looks like the default WP logging is disabled there. Having `define( ‘WP_DEBUG’, true );
    define( ‘WP_DEBUG_LOG’, true );
    define( ‘WP_DEBUG_DISPLAY’, false );` in wp_config.php doesn’t enable error_log()s to be printed in the wp-content/debug.log file, like it normally would. I even tried to circumvent that strange behavior but to no avail.

    So, on top of what Tho asked for above, can you communicate with your host to take a look on why logging is disabled there? Logging throughout the backup process is vital for us to further debug those issues.

    Best regards,
    Leonidas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.