Snapshot backup throws an error

When I try to run the backup, I get the following error:

failed to open stream: Permission denied in /var/www/vhosts/****.ch/httpdocs/wp-content/plugins/snapshot/lib/Snapshot/Helper/Session.php on line 71

Warning: file_put_contents(/5152505846436c55465f5f_session.php): failed to open stream: Permission denied in /var/www/vhosts/****.ch/httpdocs/wp-content/plugins/snapshot/lib/Snapshot/Helper/Session.php on line 71

In the screen of the Snapshot Managed Backups, I get "-1" error.

When I browse the pages in the plugin, I get:
""ERROR: Cannot create snapshot folder. Check that the parent folder is writable /home/meinsola/public_html/wp-content/uploads/snapshots"".
All the 3 folders wp-content,uploads & snapshots have 755 permissions.

I am right now unable to backup my site. Please help me with this.

  • Dimitris
    • Support Star

    Hello there Brian Haas,

    hope you're doing good today! :slight_smile:

    I tried to use the FTP details you've shared during the live chat session, but it seems that they are not working anymore. Could you please check them again and resend us some updated information? As this is public forum, you must send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question
    using this template:

    Subject: "Attn: Dimitris"

    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password/path of site in question)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Hello there Brian Haas,

    hope you're doing good today! :slight_smile:

    It seems that this was a more generic issue, as the same error was coming up when trying to upload an image in Media Library too:

    I noticed that there was an option in Settings->Media that was specifying another path than the one that I was seeing via FTP, so I changed that to the default path
    wp-content/uploads/ and this seems that resolved the media uploading error.
    You can see the older path in the Support Notes here:
    yourdomain.com/wp-admin/admin.php?page=wpmudev-support

    As before checking Media Library, I tried to delete and re-install Snapshot, you need to re-activate Managed Backups and give it a try. Let me know how that goes! :slight_smile:
    yourdomain.com/wp-admin/admin.php?page=snapshot_pro_managed_backups

    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.