Snapshot backups fail

Snapshot backups do not succeed as the I/O limits are hit.

  • Nithin
    • Support Wizard

    Hi Paul Hinderer,

    Hope you are doing good today. :slight_smile:

    I further troubleshooted the issue and tried adding more tweaks in the Snapshot plugin side to see how the Managed Backup in Snapshot behaves.

    Tested further by adding:

    define('SNAPSHOT_MB_BREADTH_FIRST', true);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define( 'SNAPSHOT_BACKTRACE_ALL', true );

    And:

    define( 'SNAPSHOT_IGNORE_SYMLINKS', true );
    define( 'SNAPSHOT_FORCE_ZIP_LIBRARY', 'archive' );

    In the wp-config.php but still, the Managed Backup is still throwing REQUEST TIMEOUT error. It’s quite common for the I/O to increase if there are any server resources shared among other sites hosted.

    I’m bringing this into our Second Level Support(SLS) team to see whether there is any further tweaks, improvements that could be done to resolve this, or not.

    Please do note that SLS works on a complex task, and have a slow response time. Will keep you posted once we get further feedback asap.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Paul,

    Thanks for the details, I’m passing this information to our team, so it would be helpful in giving a closer look at this issue. Will keep you updated once we finish troubleshooting, and running more extensive tests regarding this.

    Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Paul Hinderer,

    Our team was working on your website, so that might have created the mentioned backup during the test. I’m checking regarding the status of the issue with our team and will get back to you once I get further feedback regarding what are the changes made, and what all should be done in other VentralIP websites asap.

    Regards,

    Nithin

  • Tho Bui
    • Staff

    Hello Paul Hinderer,

    I hope you are well today!

    I checked in your site and see have some large files, it’s required more time to processing so I reject these from the backup file and see it’s working as well. You can go to Snapshot->Managed Backup click on Show Log and see the detail the list file rejected from the backup file.

    So regarding your issue, to make sure Snapshot working correctly, I suggest you get rid of the large file from the backup. You have 2 ways to do it:

    1. You can set the list large files to exclude from the section Global File Exclusions of Snapshot->Settings.

    2. I have prepared an MU plugin this will allow you to limit the max file size, which you can use as a guide here :

    https://gist.github.com/wpmudev-sls/61931bd5998de50aa32e3efb9d1224b0

    You can download a zip, unzip it and upload file snapshot-backup-reject-large-file.php to your wp-content/mu-plugins folder. If that folder doesn’t exist you can simply create it.

    After you activated it, you can define the max backup file size in bytes to wp-config.php file, default is 10MB, ex:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 10 * 1024 * 1024 );

    I installed this MU as a plugin in your plugins, so you can deactivate it if you don’t use.

    If you are not familiar with mu-plugins you can read about them here:

    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    or you can paste it in your child theme’s functions.php file.

    Kind Regards,

    Tho Bui

  • Paul Hinderer
    • WPMU DEV Initiate

    Hi Tho,

    I have installed Snapshot Pro into thill.com.au – I also installed the plugin you supplied – I updated the wp-config.php with the exact settings you used for sydneypropsphotostudios and put in exactly the same file exclusions you did – however all backups fail at about 51%

    I don’t think I will be able to get this working for my other sites at VentraIP – maybe it is a limitation of the shared hosting they have.

    As mentioned previously with sydneypropsphotostudios we are paying for additional resources.

    My other clients are not prepared to pay for more resources.

    Kind regards,

    Paul

  • Tho Bui
    • Staff

    Hey there Paul Hinderer,

    The first, that’s good if you can contact your hosting provider to ask them to increase your maximum execution time. If this still not working with you, can you provide us with full access credentials to it so I could do the checks?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Tho Bui"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP/cPanel credentials (host/username/password)

    Kind regards,

    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.