Snapshot cannot upload file to Google Drive

:Failed to start the resumable upload
2016-08-27 06:11:58: Sending Archive: 758.22 KB
2016-08-27 06:11:58: Destination: google-drive: DB
2016-08-27 06:11:58: Connecting to Google Drive
2016-08-27 06:11:58: Sending file to directory: 0B-4MSnOK0W-eODFrWkt6YnU4UFU
2016-08-27 06:11:58: ERROR: Error: Could not send file
Google_0814_Exception: Failed to start the resumable upload in /home/

Stack trace:

#0 /home/ Google_0814_Http_MediaFileUpload->getResumeUri()

#1 /home/ Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\n\x00\x00\x00\x08\x00[\\\x13I\xA6...')

#2 /home/ SnapshotDestinationGoogleDrive->send_file('/home/69509-539...')

#3 /home/ SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/69509-539...')

#4 /home/ WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker))

#5 /home/ WPMUDEVSnapshot->process_item_remote_files(1471605847)

#6 /home/ WPMUDEVSnapshot->snapshot_remote_file_cron_proc()

#7 /home/ do_action_ref_array('snapshot_remote...', Array)

#8 {main}
:Failed to start the resumable upload

snapshot giving me this error in log

can u please check it?I've enabled the support access

  • Nithin

    Hi Ega,

    Hope you are doing good today. :slight_smile:

    I checked your website, and made a test Snapshot, and it seems like the archive is failing to send the file to Google Drive Destination. The errors seems to be related to Google Drive not being configured properly, could you check, and confirm whether you have configured Google Drive properly, as shown in the instructions:

    Please let us know how that goes, so that we could give a closer look. Have a nice weekend. :slight_smile:

    Kind Regards,

  • Noah Henscheid

    I'm a bit late to the party here. I found this thread after dealing with the same problem. I had checked my oAuth settings, client ID, client secret, etc. Further, when I tested the connection (under the Snapshot plugin Destinations settings page), it said that it was connecting successfully.

    Finally, after enough digging around, I found that I completely skipped past actually enabling the dang API!

    Turns out that you can have the settings all configured, and when you test the connection it technically will be successful.

    But in order to actually push the local snapshot to Google Drive, you have to make sure the API that you set up is set to enabled.

    Here's a screenshot of the page I'm talking about:

    You can access this page by logging into your API Console, selecting your project (in my case I have named it WPMU Dev Snapshots) and clicking on the Dashboard (in case it doesn't open to that page automatically). If your Drive API is enabled, you'll see this graph, plus a little, blue "filled" icon next to Google Drive API.

    Hope this helps anyone who stumbles onto this page. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.