[Snapshot] Can't upload to S3 Wasabi storage

I have set Snapshot to do backups and save them to a Wasabi S3 drive. I have noticed on the sites that I have set it up that it seems like the upload is taking forever.

I have tested the upload speed to Wasabi, the speed is good and also I tried another plugin that does backups and has an S3 upload and it is doing it at the fraction of the time.

I have one Snapshot where it has been uploading for the last few hours while the other program saved it and uploaded it in like 10 minutes.

Please advice.

  • Sanowar Prince
    • Staff

    Hi Raymar,

    I am sorry to know that you are having a problem while using Snapshot Pro.

    I can see the issue on your site. I have reported this issue to our developer and they will give a closer look on this. Please note, developer’s response might be slower than usual staff response, so we appreciate your patience on this.

    Best regards,


  • Tho Bui
    • Staff

    Hey there Raymar,

    I hope you are well today!

    I tried a test by creating the staging site from the backup and I don’t see any issue. I checked and see your system variable wait_timeout just 30s. It seems lower, the default of this is 28800s.

    So can you contact the host server to increase this value and then try a new test?

    Hope this help!

    Kind Regards,

    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.