Snapshot Connection Timed Out

I keep getting a connection time out message when the snapshot gets to Media section.

Upped the RAM to 98MB, set_time_limit to 60. Used both local and S3 backup options.

Just tables backup finished fine.

Snapshot log:

WordPress Version 3.5
PHP Version 5.2.17
MySQL Version 5.5.29
Is Multisite No
WP_CRON Snapshot uses WP_CRON to run automated backups. If you have disabled WP_CRON via your wp-config.php you will not be able to schedule snapshots.
WP_CRON Enabled.
_SESSION Snapshot uses _SESSIONS to store temporary information about database tables and files during the backup and restore processing. Sessions are a default part of PHP.
Session save path: /tmp
Session save path is a valid directory.
Session save path is writeable.
Folder Permissions Writable (0755) – /wp-content/uploads/snapshots
Writable (0755) – /wp-content/uploads/snapshots/_backup
Writable (0755) – /wp-content/uploads/snapshots/_locks
Writable (0755) – /wp-content/uploads/snapshots/_logs
Writable (0755) – /wp-content/uploads/snapshots/_restore
PHP runtime information
Display Errors Off
Error Reporting 4983 - E_ERROR, E_WARNING
Magic Quotes 1
Max Execution Time (seconds) 60 The value displayed can be adjusted by Snapshot PHP scripts.
Memory Limit 98M - WP_MEMORY_LIMIT defined by WordPress wp-config.php.
Open Basedir Off
Safe Mode Off
ZLib Compression Off

  • Paul
    • The Green Incsub

    @Mitchell Sholly,

    Previous successful backups came in around 1GB in size.

    Were these from Snapshot or some other backup tool? Seems some other members are running into a similar issue. They have run some other backup tool which creates a backup under their /wp-content/uploads folder. Then when you switch to Snapshot it is trying to included the large previous backups into the new archive.

    You best option is to FTP or use your hosting control panel file viewer. And see what large files you have. Then you want to go to Snapshots > Settings and exclude these large files from all backups.

    As for the timeout Snapshot internally sets this to 300 seconds.

  • Timothy
    • Chief Pigeon

    Hello, hope you're well.

    Just following up on some threads here and noted that we've not heard from you in a while.

    If you're still looking for some assistance on this thread then please by all means reopen it or create a fresh thread for any new questions.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.