snapshot cpu usage issue on hostgator

Hi,
One of my client's got a CPU warning on their shared hostgator account and it appears to be related to snapshot. I'm pasting below some of what was in the email she got. They temporarily shut down her site until it was deactivated. can you please tell me what could have caused this? she has daily snapshot cloud backups enabled:

CPU Seconds used in the past hour: 2671.8, 75% CPU
Thu Jun 8 09:04:32 CDT 2017
Running Processes:
trish 85556 57.0 0.1 388756 92372 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 0.0 0.0 362120 64652 ? RN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Running Queries:
*************************** 1. row ***************************
USER: trish_cpm
DB: trish_cpm
STATE:
TIME: 0
COMMAND: Sleep
INFO: NULL
*************************** 2. row ***************************
USER: trish_cpm
DB: trish_cpm
STATE:
TIME: 0
COMMAND: Sleep
INFO: NULL

Open connections

Current Site Requests:
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa
108.179.232.15 stripclubtallahassee.com /wp-admin/admin-ajax.php?action=snapshot-full_backup-respa

Reference: ui
Server: gator4233.hostgator.com
Brand: hostgator
Srv. Type: cpanel
Created: Sat Sep 12 00:28:12 2015
Acct Type: Shared
Plan: Business
User: trish
U. Domain: stripclubtallahassee.com
Email: pettway12345@gmail.com
IP: 108.179.232.15 (shared)

Doc Root: /home3/trish/public_html
Shell: /usr/local/cpanel/bin/jailshell

CPU Usage: 78.5% (warning)
LimitPHP: Limit file exists. (warning)
Varnish: stripclubtallahassee.com is cached. (warning)

Snapshot 1
trish 85556 28.5 0.1 388756 92372 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 57.0 0.1 385452 88664 ? RN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Snapshot 2
trish 85556 28.5 0.1 388756 92372 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 60.0 0.1 387576 90760 ? RN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Snapshot 3
trish 85556 28.5 0.1 388756 92372 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 62.0 0.1 388756 92376 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Snapshot 4
trish 85556 28.5 0.1 388756 92372 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 62.0 0.1 388756 92376 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85750 0.0 0.0 294768 12388 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Snapshot 5
trish 85556 30.5 0.1 387472 91428 ? RN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85638 62.0 0.1 388756 92376 ? SN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php
trish 85750 0.0 0.0 324252 26532 ? RN 09:04 0:00 /usr/bin/php /home3/trish/public_html/wp-admin/admin-ajax.php

Current load: 09:04:33 up 230 days, 7:43, 0 users, load average: 0.03, 0.01, 0.00

    Nazmul H. Rupok

    Hi there,

    Hope you are doing well today. When you run a backup, by the nature of the process, it will require an additional memory (the process is reading all the database tables and files (depending on the options chosen) and creating a backup file). If you have higher resources, it will speed up the process to finish the backup quickly. So it should be fine if it's not interfering anything else that running on your site.

    Could you try changing chunk size to reduce server load and see if that makes any difference.
    You can do that by placing this piece of code inside your wp-config.php file just above /* That’s all, stop editing! Happy blogging. */ line:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);

    Before adding this code make sure there’s no backup running on your site, manual or automatic.

    Let us know if that makes any difference.

    All the best,
    Nazmul