Snapshot crashed my website and I wanted to let you know

Hi there,

I just installed snapshot and proceeded to do a back up and it crashed my site with a 500 internal server error.

I had to contact my host who replied with the following:
-----------------------------------------------
I have checked the Apache error log, and there appears to be a problem with the .htaccess located at /home/aborigin/public_html/.htaccess. Here is the exact error: [Sat Apr 18 12:02:39 2015] [alert] [client 10.30.4.45] /home/******/public_html/.htaccess: Invalid command 'ur', perhaps misspelled or defined by a module not included in the server configuration

The site is now back up, as I have resolved the issue. It appears as though that when the plugin went to write to the file, it accidentally uncommented a line that should have been commented out. Here was the line in question: # END HTML5 Boilerplate ur server does not allow PHP directives to be set via .htaccess. In that # case you must make this change in your php.ini file instead. If you are I saw the "ur" at the beginning of the sentence and changed it to "# Your", which fixed the problem.

----------------------------------------

Does this make sense to you? Is this something that can be resolved from your end or do i need to not use this plugin again? Any advice you can offer would be appreciated.

Thank you

  • Michelle Shull

    Hi, Scott!

    Are you seeing this when you create the Snapshot, or when you're trying to restore it?

    I've not seen this particular error with Snapshot before, I did a quick search of the forum to see if I could find other members who had a similar issue, and I haven't thus far. I'm also not seeing it on my own sandbox site, which leads me to believe there may be another issue here.

    Let's do a test, since we know the fix here already.

    Disable every other plugin you have installed, and switch to a default WordPress theme. It will only be for the duration of the test, and you won't lose any settings.

    With only Snapshot active, try taking another snapshot. Try restoring it on a test site, if you have one available (and you always should.) Does it fail here? If not, we know it's not Snapshot that's responsible for your error here. If you don't have a test site, (and you really should) I'm going to have you send me your completed Snapshot and I'll try to restore it on one of my vanilla test sites.

    https://premium.wpmudev.org/contact/

    Subject: "Attn: Michelle Shull"

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Post here if you send so I know to look for it. :slight_smile:
    Thanks!

  • Scott

    Hi Michelle,

    Deactivated all plugins bar the WPMU dashboard and then re added snapshot and tried again and it happened again.

    I then switched to stock 2015 theme and tried again and it worked so obviously something with the theme which doesn't really matter as im wanting to use snapshot to upgrade an entire site and it uses a different theme so i guess there's no point worrying any further about it?

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.