Snapshot does not create snapshots

Hi,
I have just installed Snapshot on 7 of my sites. The first 5 work fine, the last two sites do run but no archive is created. It says for a short will ''creating archive (abort)'', then nothing happens.

Please assist.
-Jos

  • Adam Czajczyk
    • Support Gorilla

    Hey Jos,

    I hope your well today and thank you for your question!

    I wonder if those two Snapshot instances are installed on different server(s) than the other ones? What is the hosting provider? Please advise.

    My guess would be the issue is strictly related to the file permissions. That said, could you check please if /wp-content/uploads/ permissions are set to 0755 (read+write+execute for owner, read+execute for group and others)? You can do this by accessing your site via FTP or via a web file manager of your hosting panel.

    Let me know please if it helped.

    Regards,
    Adam

  • Jos
    • Site Builder, Child of Zeus

    Hi Adam,

    thanks for the quick response. No, all sites are on the same server.
    I changed the upload directory tot 755 as you suggested, no change. The snapshot processes for a few seconds and then stops.

    Regards,
    Jos

  • Adam Czajczyk
    • Support Gorilla

    Hello Jos,

    I hope you're well today and I apologize for keeping you waiting!

    Let me answer your last question first: usually you're getting your first response faster than next responses because with your first question is always put in front of the eyes of one of us by the system. It doesn't mean that I (nor does anyone of us here) forget about you - it's just that some issues need further examination, thus taking more time and sometimes we had a lot of questions to deal with and those questions need to be queued somehow. That said, adding a new post to an existing (not answered yet) thread doesn't speed-up the process, nor does opening duplicated thread. Of course this is not a perfect system but it let's us replay as fast as possible (not omitting any questions) and we're constantly working on improving it. I myself am also trying to improve my workflow as I'm a relatively new guy here, so that you don't have to wait anymore.

    That being said, have you run a plugin conflict test as described in this article (take a look at the flowchart please)?

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If not, please do so and let me know of the results. If it doesn't help, could you please re-enable the support access once again?

    Regards,
    Adam

  • Jos
    • Site Builder, Child of Zeus

    Thanks Adam, I understand your approach but I think 4 days is a long time to follow up.

    Anyway, what I noticed is that when I create a snapshot without selecting any files in 'What files to archive?' everything works fine. The snapshot runs, creates an archive and copies this to my dropbox destination. As soon as I select all checkboxes in 'Included selected files' the snapshot runs but no archive is copied to my dropbox destination. In the snapshot overview you see behind Desitnation 'pending: 3'.

    I have granted you access.

    Let me know.
    regards,
    Jos

  • Adam Czajczyk
    • Support Gorilla

    Hello Jos,

    I hope you're well today!

    I've performed some test on my sandbox and I'd like you to try changing some settings. I've attached a few screenshots for your convenience. Could you please follow the steps below (not necessarily implementing them all at once, just one-by-one rather) and let me know the results?

    1) On a "Snapshots" -> "Destinations" page go to your Dropbox settings, set a new destination folder (different than the one that is used at the moment) and check the checkbox "Force Re-Authorize with Dropbox":wink:

    2) On a "Snapshots" -> "Settings" page increase the Memory Limit (mine is set to 256M but yours will probably be higher)

    3) Again on the same page: change the "Backup folder" to something new

    4) ...and decrease the Segment Size

    Let me know please how that worked for you!

    Regards,
    Adam

  • Jude
    • DEV MAN

    Hi there @Jos

    Sorry the response took a while longer than expected. Appreciate your patience.

    I'd like to take a look at the two sites, what Im thinking is if 5 go through then it has something to do with the sites themseilves. Im thinking the sites are larger and there is some sort of restriction either on memory or process time set by your host. Can you quickly take a look at the memory on each process and increase each a bit as shown here.

    docs.woothemes.com/document/increasing-the-wordpress-memory-limit/
    davidwalsh.name/increase-php-script-execution-time-limit-ini_set

    Also temporarily disable other plugins for the duration of the snapshot process.

    Also if that does not help, can you please send in

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    - phpMyAdmin details ( To check database )
    - MySQL details ( IF you dont have phpmyadmin)

    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Cheers
    Jude

  • Jos
    • Site Builder, Child of Zeus

    Hi Jude,
    thanks for the reply. I removed everything from my website, including snapshots, destinations and plugin. After a reinstall it seems to works fine now. Wish I tried that before.

    Thanks again,
    Jos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.