Snapshot does not save backup file

I've setup a S3 destination and tested it – it works.
I've also setup a job to run every day at midnight and I also clicked "Run Now" yesterday. This should in my mind have resulted in a backup file in the S3 bucket, but I only see the connection test file in there.

Can you help me debug my setup..?

  • Paul
    • The Green Incsub

    @Tejs,

    In wp-admin go to Snapshots > All Snapshots. What do you see on the listing? Specifically the last column should show the archive created. If this is blank it means the archive are not being created.

    If you do see the archive .zip filename in the archive column then you should also see a link below that filename for the logs. The logs shows the details of the creation of the archive as well as the push to the remote destination.

    The Snapshot processing is actually in two parts. The first part is the creation of the local .zip archive. Once this is completed there is a second part which pushes the archive to the remote destination. This second part relies on the WordPress WP_Cron system for the scheduling. So if there is an issue that is where we will need to investigate.

  • Paul
    • The Green Incsub

    @Tejs,

    If that last column is empty it means the archive creation did not finish. So go back in an edit the snapshot configuration. For now don't include any file. Just database table. See if you can get it to run to completion. Once it does you will see the last column showing the archive .zip filename. This is when the second step of sending the archive to the remote destination happens.

    Then we can address the issue with the files include after.

  • Tejs
    • WPMU DEV Initiate

    OK, that made a difference..
    I changed the settings of the snapshot not to include any files.

    Result:

    snapshot-1392723441-140225-130612-8492ae83.zip (2.43M)
    Archives: view (1) Latest Log: view download
    Destination: 1 Complete

    I just checked and the file is on S3 as well.

    What next..?

  • Paul
    • The Green Incsub

    @Tejs,

    Also, I'm not sure if you are creating the archive interactively. If you are at the top of the progress bars you should see the memory information reported. Can you reply back how much memory you are using during the archive creation?

  • Paul
    • The Green Incsub

    @Tejs,

    I don't know what you mean with: creating the archive interactively

    Ok. Fair enough. what I mean is there are two way to create an archive. First is the 'interactive' mode. Basically, from the configuration form screen where you set what files, database tables to include in the archive. When you click the submit button the archive is created on the next screen. You will see a listing of the tables and progress bars showing the completed tables.

    For non-interactive archive creation you set snapshot to run as a scheduled task. You can set the interval via the configuration screen.

    Lastly, there is the 'run now' option which is executed from the All Snapshots listing.

    Can you try the interactive mode? As this will provide memory information. It could be that you have some large files that cannot be included in the archive.

  • Tejs
    • WPMU DEV Initiate

    OK, that is a little bit weird..

    I switch it from "Once Daily" to "Run Immediate" and then it completed 100%.
    I was able to see all the bars and that. Max memory usage was 57 mb.

    snapshot-1392723441-140225-140805-2b7e2d08.zip (77.55M)
    Archives: view (2) Latest Log: view download
    Destination: 1 Pending, 1 Complete

    It is not on S3 yet, I guess that is why it says Pending.

  • Paul
    • The Green Incsub

    @Tejs,

    It is not on S3 yet, I guess that is why it says Pending.

    Correct. If you go back to the All Snapshots listing you will see a couple of timestamps in the right upper area above the table listing. One should say something like 'Next Send...'. This is the process which runs every 5 minutes to check for files needing to be pushed to external destinations.

    For now set the scheduled interval to once hourly or just twice daily. See if we can do a hands off review in a few hours. Also on the snapshot configuration screen just about where you set the scheduled interval there is an input field to control the number of local archive. Set this to some low number like 1 to 3. This will keep the local disk space used minimal. And snapshot will not delete archive which have not been send out to S3.

  • Tejs
    • WPMU DEV Initiate

    Hi Paul, I've now had the time to look at the status again and unfortunately the scheduled back-up didn't complete. As far as I can see nothing happened since I ran the job interactively.

    snapshot-1392723441-140225-140805-2b7e2d08.zip (77.55M)
    Archives: view (2) Latest Log: view download
    Destination: 2 Complete

    I will now try to change only the scheduling and run interactive again.

  • Paul
    • The Green Incsub

    @Tejs,

    I've now had the time to look at the status again and unfortunately the scheduled back-up didn't complete. As far as I can see nothing happened since I ran the job interactively.

    The scheduled tasks as mentioned on that page require the functionality of WP_Cron which does the actually scheduling. Basically when you set snapshot to run at a certain interval it simply registers a function call with the WP_Cron scheduling system to occur at a certain time in the future.

    So you might be having trouble with the WP_Cron it requires front-end traffic to keep it current an is somewhat of a pain to debug.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.