snapshot doesn't seem to want to run on

It seems to be working on all the other domains but not this one. I create a snapshot, schedule it, and then click run now. But, it never starts.... A cron issue with just his one domain maybe?

  • Adam Czajczyk

    Hello Gary,

    I hope you're well today and thank you for your question!

    It may be a cron issue however there's also a number of other factors that can cause this. That said, I'd like to ask you if you could grant me a support access to your site so I could take a closer look? To do this please follow this guide:

    It would be also great if you could follow the steps below first:
    - add these lines to your wp-config.php file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    This will turn on WP debugging feature and write messages to /wp-content/debug.log file

    - try running snapshot again (a few times preferably)

    - share the /wp-content/debug.log content with me.


  • Gary

    I did this and shortly afterwards the whole site is dead. with this error.

    Warning: require_once(/home/gary03181959/ failed to open stream: No such file or directory in /home/gary03181959/ on line 31

    Fatal error: require_once(): Failed opening required '/home/gary03181959/' (include_path='.:disappointed:usr/local/lib/php:disappointed:usr/local/php5/lib/pear') in /home/gary03181959/ on line 31

    Please help... soon.

    I have taken the debug lines back out of wp-config.php for now. but its still down.

  • Adam Czajczyk

    Hello Gary!

    Thanks for this information!

    I have taken the debug lines back out of wp-config.php for now. but its still down.

    I assure you that the debug didn't caused that error. Actually, it's a fortunate thing that you were able to run it before the site failed completely.

    I can see that your site is up and running at the moment. Did you manage to repair it/restore from backup?

    The error you've found in the debug.log file means that either the "wp-load.php" file (which should be located in your WP install root directory) is missing or there are too strict file permissions for wp-content.php file. This happens sometimes and also some host such as Dreamhost are know for pushing security updates to customers servers that result in mistakenly hardened permissions.

    This is usually solved by changing wp-config.php file permission to at 644 (meaning: "read + write" for owne, "read" for group and others).

    That being said, seeing that the site is up and running back again, I've tested snapshot once again. When run manually, it works fine. You can test it for yourself by going to your dashboard's

    "Snapshot" -> "All Snapshots" -> [select snapshot] -> edit page

    and then changing interval to "Run immediately" and saving settings.

    This leads me to thinking that the WP Cron is a main culprit here. Cron is a tool that lets you run tasks periodically in background. The "real" Cron is a server application triggered by server's timer. It's very reliable and accurate. The WP Cron is a simple script that aims to imitate the "real" Cron but heavily depends on site's traffic. It can also be broken in rare cases by strict security settings of the server.

    That being said, I'd suggest switching your WordPress from WP Cron to real Cron. You should be able to find out if it helped in about a day (since your default snapshot interval is set to a day).

    The switch from WP Cron to server's Cron can be done in a few ways. One would be a bit "geeky" and is described in this post:

    If you're managing your server via cPanel, here's a handy video guide on this:

    Would you give it a try and let me know if it helped?


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.